summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-07-08 15:07:12 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-07-08 15:07:12 +0000
commitaac0d5435ce89763ebabb44062b859f7311b2125 (patch)
tree1f30c33e6b7b8162d11a6d36f7772648ea1fc4dd
parentFixed rcadd/rcdel example and re-rolling catalyst 1.1.10. (diff)
downloadgentoo-aac0d5435ce89763ebabb44062b859f7311b2125.tar.gz
gentoo-aac0d5435ce89763ebabb44062b859f7311b2125.tar.bz2
gentoo-aac0d5435ce89763ebabb44062b859f7311b2125.zip
Fixed quoting in stage1 profile check.
-rw-r--r--src/catalyst/ChangeLog6
-rw-r--r--src/catalyst/targets/stage1/stage1-chroot.sh4
2 files changed, 7 insertions, 3 deletions
diff --git a/src/catalyst/ChangeLog b/src/catalyst/ChangeLog
index 9b056e4039..e929249eb5 100644
--- a/src/catalyst/ChangeLog
+++ b/src/catalyst/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gentoo/src/catalyst
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/ChangeLog,v 1.198.2.87 2005/07/08 13:15:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/ChangeLog,v 1.198.2.88 2005/07/08 15:07:12 wolf31o2 Exp $
+
+ 08 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ targets/stage1/stage1-chroot.sh:
+ Fixed quoting in stage1 profile check.
08 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org>
examples/livecd-stage2_template.spec:
diff --git a/src/catalyst/targets/stage1/stage1-chroot.sh b/src/catalyst/targets/stage1/stage1-chroot.sh
index 25e13d9bb6..ee70eb1d0e 100644
--- a/src/catalyst/targets/stage1/stage1-chroot.sh
+++ b/src/catalyst/targets/stage1/stage1-chroot.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/targets/stage1/Attic/stage1-chroot.sh,v 1.29.2.6 2005/07/07 21:23:11 rocket Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/targets/stage1/Attic/stage1-chroot.sh,v 1.29.2.7 2005/07/08 15:07:12 wolf31o2 Exp $
portage_version=`/usr/lib/portage/bin/portageq best_version / sys-apps/portage \
| cut -d/ -f2 | cut -d- -f2,3`
@@ -57,7 +57,7 @@ export clst_buildpkgs="$(/tmp/build.py)"
STAGE1_USE="$(portageq envvar STAGE1_USE)"
## Sanity check profile
-if [ -z ${clst_buildpkgs} ]
+if [ -z "${clst_buildpkgs}" ]
then
echo "Your profile seems to be broken."
echo "Could not build a list of build packages."