summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Stubbs <jstubbs@gentoo.org>2005-01-02 04:24:39 +0000
committerJason Stubbs <jstubbs@gentoo.org>2005-01-02 04:24:39 +0000
commit8dff410cb2eed96a0b0e71016f225a7ce8e41719 (patch)
treed8fb10f573cc4f1c42e5ae559a7c923c1fe6e599
parentadd info about parent and cascading profiles (diff)
downloadportage-cvs-8dff410cb2eed96a0b0e71016f225a7ce8e41719.tar.gz
portage-cvs-8dff410cb2eed96a0b0e71016f225a7ce8e41719.tar.bz2
portage-cvs-8dff410cb2eed96a0b0e71016f225a7ce8e41719.zip
Modified header check to use the year of the mtime of the ebuild rather
than the current year.
-rw-r--r--ChangeLog7
-rwxr-xr-xbin/repoman10
2 files changed, 11 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index f717df8..496f3bb 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for Portage; the Gentoo Linux ports system
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Id: ChangeLog,v 1.796.2.30 2004/12/23 02:27:03 jstubbs Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Id: ChangeLog,v 1.796.2.31 2005/01/02 04:24:39 jstubbs Exp $
MAJOR CHANGES in 2.0.51:
1. /var/cache/edb/virtuals is no longer used at all. It's calculated now.
2. /var/cache/edb/world is now /var/lib/portage/world.
3. /etc/portage/profile/virtuals is _USER_ configs only.
+ 02 Dec 2005; Jason Stubbs <jstubbs@gentoo.org> repoman: Modified header check
+ to use the year of the mtime of the ebuild rather than the current year.
+
24 Dec 2004; Jason Stubbs <jstubbs@gentoo.org> portage.py: Removed assumption
that /etc/make.profile/make.defaults must exist for configdict["defaults"] to
be populated (and thus ARCH prepended to USE).
diff --git a/bin/repoman b/bin/repoman
index 2d4a282..d363ebc 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1,7 +1,7 @@
#!/usr/bin/python -O
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/repoman,v 1.98.2.4 2004/12/03 05:27:49 carpaski Exp $
+# $Header: /local/data/ulm/cvs/history/var/cvsroot/gentoo-src/portage/bin/repoman,v 1.98.2.5 2005/01/02 04:24:39 jstubbs Exp $
# Next to do: dep syntax checking in mask files
# Then, check to make sure deps are satisfiable (to avoid "can't find match for" problems)
@@ -25,6 +25,7 @@ from time import *
from fileinput import input
from grp import getgrnam
from stat import *
+from datetime import datetime
def err(txt):
@@ -185,7 +186,7 @@ def help():
print
print green(exename+" "+version)
print " \"Quality is job zero.\""
- print " Copyright 1999-2004 Gentoo Foundation"
+ print " Copyright 1999-2005 Gentoo Foundation"
print " Distributed under the terms of the GNU General Public License v2"
print
print bold(" Usage:"),turquoise(exename),"[",green("option"),"] [",green("mode"),"]"
@@ -1012,7 +1013,8 @@ for x in scanlist:
fails["KEYWORDS.invalid"].append(x+"/"+y+".ebuild: %s (profile invalid)" % mykey)
#syntax checks
- gentoo_copyright = re.compile(r'^# Copyright 1999-' + strftime("%Y", gmtime()) + r' Gentoo Foundation')
+ myear = datetime.fromtimestamp(os.stat(checkdir+"/"+y+".ebuild")[ST_MTIME]).year
+ gentoo_copyright = re.compile(r'^# Copyright 1999-' + str(myear) + r' Gentoo Foundation')
gentoo_license = re.compile(r'^# Distributed under the terms of the GNU General Public License v2$')
cvs_header = re.compile(r'^#\s*\$Header.*\$$')
ignore_line = re.compile(r'(^$)|(^(\t)*#)')