summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-03-30 15:48:41 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-03-30 15:48:41 +0000
commit00c59b40f4eb79cc7fd607cf7e40072289de6bc1 (patch)
treeb50a033b2b6e2151766a09b398545a1e13ae5386
parentFix compilation with a 2.6.19 kernel (bug #172727). (diff)
downloadgentoo-2-00c59b40f4eb79cc7fd607cf7e40072289de6bc1.tar.gz
gentoo-2-00c59b40f4eb79cc7fd607cf7e40072289de6bc1.tar.bz2
gentoo-2-00c59b40f4eb79cc7fd607cf7e40072289de6bc1.zip
apply patch for PPC64, so configure won't fail on it
(Portage version: 2.1.2.2)
-rw-r--r--app-emacs/auctex/ChangeLog6
-rw-r--r--app-emacs/auctex/auctex-11.84-r1.ebuild6
-rw-r--r--app-emacs/auctex/files/auctex-11.84-ppc64_configure.patch34
3 files changed, 43 insertions, 3 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index 0b051fd5ca85..4da2806be098 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emacs/auctex
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.54 2007/03/04 11:24:38 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.55 2007/03/30 15:48:41 opfer Exp $
+
+ 30 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/auctex-11.84-ppc64_configure.patch, auctex-11.84-r1.ebuild:
+ apply patch for PPC64, so configure won't fail on it
*auctex-11.84-r1 (04 Mar 2007)
diff --git a/app-emacs/auctex/auctex-11.84-r1.ebuild b/app-emacs/auctex/auctex-11.84-r1.ebuild
index 6e89859d833b..e4ec78526d7f 100644
--- a/app-emacs/auctex/auctex-11.84-r1.ebuild
+++ b/app-emacs/auctex/auctex-11.84-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.84-r1.ebuild,v 1.1 2007/03/04 11:24:38 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.84-r1.ebuild,v 1.2 2007/03/30 15:48:41 opfer Exp $
inherit elisp eutils latex-package autotools
@@ -25,8 +25,10 @@ src_unpack() {
# skip XEmacs detection. this is a workaround for emacs23
epatch "${FILESDIR}/${P}-configure.diff"
# allow compilation of Japanese TeX files, fixed in upstream's CVS
- # not needed for next release
+ # not needed for next release (>=11.85)
epatch "${FILESDIR}/${P}-japanes.patch"
+ # detection of Emacs fails on ppc64 with version 21, see bug #131761
+ use ppc64 && epatch "${FILESDIR}/${P}-ppc64_configure.patch"
}
src_compile() {
diff --git a/app-emacs/auctex/files/auctex-11.84-ppc64_configure.patch b/app-emacs/auctex/files/auctex-11.84-ppc64_configure.patch
new file mode 100644
index 000000000000..3ca7e5a4a57a
--- /dev/null
+++ b/app-emacs/auctex/files/auctex-11.84-ppc64_configure.patch
@@ -0,0 +1,34 @@
+--- /tmp/configure 2007-03-02 13:33:25.000000000 +0100
++++ configure 2007-03-02 13:35:44.000000000 +0100
+@@ -2032,31 +2032,6 @@
+ { echo "$as_me:$LINENO: result: \"${emacsprefix}\"" >&5
+ echo "${ECHO_T}\"${emacsprefix}\"" >&6; }
+
+-
+-{ echo "$as_me:$LINENO: checking if ${EMACS_NAME} is recent enough" >&5
+-echo $ECHO_N "checking if ${EMACS_NAME} is recent enough... $ECHO_C" >&6; }
+-
+- elisp="(cond ((< emacs-major-version 21) \"no\")
+- ((> emacs-major-version 21) \"yes\")
+- ((< emacs-minor-version 01) \"no\")
+- (t \"yes\"))"
+- OUTPUT=./conftest-$$
+- echo "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if (stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))" >& 5 2>&1
+- "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if (stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))" >& 5 2>&1
+- result="`cat ${OUTPUT}`"
+- echo "=> ${result}" >& 5 2>&1
+- rm -f ${OUTPUT}
+-
+-{ echo "$as_me:$LINENO: result: ${result}" >&5
+-echo "${ECHO_T}${result}" >&6; }
+-if test "${result}" != "yes"
+-then
+- { { echo "$as_me:$LINENO: error: This package requires at least ${EMACS_NAME} version 21.1 Aborting!" >&5
+-echo "$as_me: error: This package requires at least ${EMACS_NAME} version 21.1 Aborting!" >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-
+-
+ { echo "$as_me:$LINENO: checking for MULE support" >&5
+ echo $ECHO_N "checking for MULE support... $ECHO_C" >&6; }
+