summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-08-05 21:15:11 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-08-05 21:15:11 +0000
commit1e9ca7c48e0786a623da24e28c01be0c94b821c2 (patch)
tree8b8694fb6398aa827a87be03c4362b4a51cd5a8d
parentInstall the documention for incompatibilities with busybox, and optionally, t... (diff)
downloadgentoo-2-1e9ca7c48e0786a623da24e28c01be0c94b821c2.tar.gz
gentoo-2-1e9ca7c48e0786a623da24e28c01be0c94b821c2.tar.bz2
gentoo-2-1e9ca7c48e0786a623da24e28c01be0c94b821c2.zip
Version bump. Add static-libs USE flag (bug #461724), remove unnecessary .la files.
(Portage version: 2.1.13.2/cvs/Linux x86_64, signed Manifest commit with key 5C350883)
-rw-r--r--net-misc/lldpd/ChangeLog9
-rw-r--r--net-misc/lldpd/files/lldpd-0.7.6-include-unistd.patch12
-rw-r--r--net-misc/lldpd/lldpd-0.7.6.ebuild85
3 files changed, 105 insertions, 1 deletions
diff --git a/net-misc/lldpd/ChangeLog b/net-misc/lldpd/ChangeLog
index 04b19bf84fbf..879bfa2c1011 100644
--- a/net-misc/lldpd/ChangeLog
+++ b/net-misc/lldpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/lldpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/lldpd/ChangeLog,v 1.9 2013/03/28 20:14:56 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/lldpd/ChangeLog,v 1.10 2013/08/05 21:15:11 chutzpah Exp $
+
+*lldpd-0.7.6 (05 Aug 2013)
+
+ 05 Aug 2013; Patrick McLean <chutz@gentoo.org> +lldpd-0.7.6.ebuild,
+ +files/lldpd-0.7.6-include-unistd.patch:
+ Version bump. Add static-libs USE flag (bug #461724), remove unnecessary .la
+ files.
28 Mar 2013; Patrick McLean <chutzpah@gentoo.org> -lldpd-0.5.6.ebuild,
-lldpd-0.5.7.ebuild, lldpd-0.7.1.ebuild:
diff --git a/net-misc/lldpd/files/lldpd-0.7.6-include-unistd.patch b/net-misc/lldpd/files/lldpd-0.7.6-include-unistd.patch
new file mode 100644
index 000000000000..f8933541b549
--- /dev/null
+++ b/net-misc/lldpd/files/lldpd-0.7.6-include-unistd.patch
@@ -0,0 +1,12 @@
+diff --git a/src/daemon/priv-linux.c b/src/daemon/priv-linux.c
+index 68eee70..d17ec38 100644
+--- a/src/daemon/priv-linux.c
++++ b/src/daemon/priv-linux.c
+@@ -17,6 +17,7 @@
+
+ #include "lldpd.h"
+
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/net-misc/lldpd/lldpd-0.7.6.ebuild b/net-misc/lldpd/lldpd-0.7.6.ebuild
new file mode 100644
index 000000000000..157796e0c9e0
--- /dev/null
+++ b/net-misc/lldpd/lldpd-0.7.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/lldpd/lldpd-0.7.6.ebuild,v 1.1 2013/08/05 21:15:11 chutzpah Exp $
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Implementation of IEEE 802.1ab (LLDP)"
+HOMEPAGE="http://vincentbernat.github.com/lldpd/"
+SRC_URI="http://media.luffy.cx/files/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdp doc +dot1 +dot3 edp fdp graph json +lldpmed sonmp snmp static-libs readline xml"
+
+RDEPEND=">=dev-libs/libevent-2.0.5
+ snmp? ( net-analyzer/net-snmp[extensible(+)] )
+ xml? ( dev-libs/libxml2 )
+ json? ( dev-libs/jansson )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ graph? ( app-doc/doxygen[dot] )
+ !graph? ( app-doc/doxygen )
+ )"
+
+REQUIRED_USE="graph? ( doc )"
+
+pkg_setup() {
+ ebegin "Creating lldpd user and group"
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+ eend $?
+}
+
+src_prepare() {
+ # remove the bundled libevent
+ rm -rf libevent
+ epatch "${FILESDIR}"/${P}-include-unistd.patch
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --with-privsep-user=${PN} \
+ --with-privsep-group=${PN} \
+ --with-privsep-chroot=/var/lib/${PN} \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable graph doxygen-dot) \
+ $(use_enable doc doxygen-man) \
+ $(use_enable doc doxygen-pdf) \
+ $(use_enable doc doxygen-html) \
+ $(use_enable cdp) \
+ $(use_enable dot1) \
+ $(use_enable dot3) \
+ $(use_enable edp) \
+ $(use_enable fdp) \
+ $(use_enable lldpmed) \
+ $(use_enable sonmp) \
+ $(use_enable static-libs static) \
+ $(use_with json) \
+ $(use_with readline) \
+ $(use_with snmp) \
+ $(use_with xml)
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+
+ newinitd "${FILESDIR}"/${PN}-initd-1 ${PN}
+ newconfd "${FILESDIR}"/${PN}-confd-1 ${PN}
+
+ use doc && dohtml -r doxygen/html/*
+
+ keepdir /var/lib/${PN}
+}