summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-11 10:56:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-11 10:56:57 +0000
commit5e7f1406af7b5d8b0d5c3b98250b8d4567efb24e (patch)
tree9bf197c7e10c27b48c0ce27a6693354f23d6ba82
parentremove old (diff)
downloadgentoo-2-5e7f1406af7b5d8b0d5c3b98250b8d4567efb24e.tar.gz
gentoo-2-5e7f1406af7b5d8b0d5c3b98250b8d4567efb24e.tar.bz2
gentoo-2-5e7f1406af7b5d8b0d5c3b98250b8d4567efb24e.zip
Version bump. Use pregenerated docs and install to correct path wrt #294276.
(Portage version: 2.2_rc66/cvs/Linux x86_64)
-rw-r--r--media-libs/libfishsound/ChangeLog9
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0.ebuild43
2 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/libfishsound/ChangeLog b/media-libs/libfishsound/ChangeLog
index 7f1cffcc11aa..5dba9026a555 100644
--- a/media-libs/libfishsound/ChangeLog
+++ b/media-libs/libfishsound/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libfishsound
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.8 2010/03/08 06:35:48 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/ChangeLog,v 1.9 2010/03/11 10:56:57 ssuominen Exp $
+
+*libfishsound-1.0.0 (11 Mar 2010)
+
+ 11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +libfishsound-1.0.0.ebuild:
+ Version bump. Use pregenerated docs and install to correct path wrt
+ #294276.
08 Mar 2010; Sebastian Pipping <sping@gentoo.org>
libfishsound-0.9.1.ebuild, libfishsound-0.9.2.ebuild:
diff --git a/media-libs/libfishsound/libfishsound-1.0.0.ebuild b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
new file mode 100644
index 000000000000..d697cf11e1c7
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfishsound/libfishsound-1.0.0.ebuild,v 1.1 2010/03/11 10:56:57 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
+HOMEPAGE="http://www.xiph.org/fishsound/"
+SRC_URI="http://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac speex"
+
+RDEPEND="media-libs/libvorbis
+ media-libs/libogg
+ flac? ( media-libs/flac )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:doxygen:doxygen-dummy:' \
+ configure || die
+}
+
+src_configure() {
+ local myconf=""
+ use flac || myconf="${myconf} --disable-flac"
+ use speex || myconf="${myconf} --disable-speex"
+
+ econf \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${D}/usr/share/doc/${PF}" install || die
+ dodoc AUTHORS ChangeLog README
+}