summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-30 02:13:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-30 02:13:52 +0000
commitb064ba2cdbb6eb08d373b3618d62421c6287706e (patch)
tree3716795d3bb014bb52a755edee11f8324562d1d6
parentsource /etc/profile fix (diff)
downloadgentoo-2-b064ba2cdbb6eb08d373b3618d62421c6287706e.tar.gz
gentoo-2-b064ba2cdbb6eb08d373b3618d62421c6287706e.tar.bz2
gentoo-2-b064ba2cdbb6eb08d373b3618d62421c6287706e.zip
This version no longer searches for a configuration file in the current directory, and thus closes a very large security hole. A problem with resizing was also solved.
-rw-r--r--app-editors/joe/files/digest-joe-2.9.51
-rw-r--r--app-editors/joe/joe-2.9.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/joe/files/digest-joe-2.9.5 b/app-editors/joe/files/digest-joe-2.9.5
new file mode 100644
index 000000000000..a0917bf58d57
--- /dev/null
+++ b/app-editors/joe/files/digest-joe-2.9.5
@@ -0,0 +1 @@
+MD5 bc888bd53586bb54c2e46983bc9a4c97 joe-2.9.5.tgz
diff --git a/app-editors/joe/joe-2.9.5.ebuild b/app-editors/joe/joe-2.9.5.ebuild
new file mode 100644
index 000000000000..0579b6373c28
--- /dev/null
+++ b/app-editors/joe/joe-2.9.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.5.ebuild,v 1.1 2001/03/30 02:13:52 achim Exp $
+
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+SRC_URI="http://ftp1.sourceforge.net/joe-editor/${A}"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+
+ try make joe termidx
+}
+
+src_install() {
+ into /usr
+ dobin joe
+ doman joe.1
+ dolib joerc
+ for i in jmacs jstar jpico rjoe
+ do
+ dosym joe /usr/bin/$i
+ dosym joe.1.gz /usr/share/man/man1/$i.1.gz
+ dolib ${i}rc
+ done
+
+ dodoc copying INFO LIST README TODO VERSION
+}
+
+
+
+
+