summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-02-23 13:56:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-02-23 13:56:56 +0000
commit928422603abc8663e2464871a8539bf3ba24f1c2 (patch)
tree470105b93a1d7892e9ad17de406ca0c30c57657f /app-admin
parentremoved old version, bug 150172 (diff)
downloadgentoo-2-928422603abc8663e2464871a8539bf3ba24f1c2.tar.gz
gentoo-2-928422603abc8663e2464871a8539bf3ba24f1c2.tar.bz2
gentoo-2-928422603abc8663e2464871a8539bf3ba24f1c2.zip
Add a patch to fix parallel install and avoid -j1 for install then.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sudo/ChangeLog6
-rw-r--r--app-admin/sudo/files/sudo-1.7.0-parallelinstall.patch31
-rw-r--r--app-admin/sudo/sudo-1.7.0.ebuild6
3 files changed, 40 insertions, 3 deletions
diff --git a/app-admin/sudo/ChangeLog b/app-admin/sudo/ChangeLog
index 0c4f76800ecd..d255e33eff34 100644
--- a/app-admin/sudo/ChangeLog
+++ b/app-admin/sudo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/sudo
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/ChangeLog,v 1.162 2009/02/23 13:01:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/ChangeLog,v 1.163 2009/02/23 13:56:55 flameeyes Exp $
+
+ 23 Feb 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/sudo-1.7.0-parallelinstall.patch, sudo-1.7.0.ebuild:
+ Add a patch to fix parallel install and avoid -j1 for install then.
23 Feb 2009; Diego E. Pettenò <flameeyes@gentoo.org>
-sudo-1.6.9_p13.ebuild, -sudo-1.6.9_p19.ebuild:
diff --git a/app-admin/sudo/files/sudo-1.7.0-parallelinstall.patch b/app-admin/sudo/files/sudo-1.7.0-parallelinstall.patch
new file mode 100644
index 000000000000..86c0c45dd921
--- /dev/null
+++ b/app-admin/sudo/files/sudo-1.7.0-parallelinstall.patch
@@ -0,0 +1,31 @@
+Index: sudo-1.7.0/Makefile.in
+===================================================================
+--- sudo-1.7.0.orig/Makefile.in
++++ sudo-1.7.0/Makefile.in
+@@ -407,22 +407,22 @@ install-dirs:
+ $(DESTDIR)$(mandirsu) $(DESTDIR)$(mandirform) \
+ $(DESTDIR)$(noexecdir)
+
+-install-binaries: $(PROGS)
++install-binaries: install-dirs $(PROGS)
+ $(INSTALL) -O $(install_uid) -G $(install_gid) -M 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
+ rm -f $(DESTDIR)$(sudodir)/sudoedit
+ ln $(DESTDIR)$(sudodir)/sudo $(DESTDIR)$(sudodir)/sudoedit
+ $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
+ @SELINUX@ $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s sesh $(DESTDIR)$(libexecdir)/sesh
+
+-install-noexec: sudo_noexec.la
++install-noexec: install-dirs sudo_noexec.la
+ test -f .libs/$(noexecfile) && $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0755 .libs/$(noexecfile) $(DESTDIR)$(noexecdir)
+
+-install-sudoers:
++install-sudoers: install-dirs
+ test -f $(DESTDIR)$(sudoersdir)/sudoers || \
+ $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+ $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
+
+-install-man:
++install-man: install-dirs
+ $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
+ @rm -f $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
+ ln $(DESTDIR)$(mandirsu)/sudo.$(mansectsu) $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
diff --git a/app-admin/sudo/sudo-1.7.0.ebuild b/app-admin/sudo/sudo-1.7.0.ebuild
index 3d36a250cee6..20f66d60c2cc 100644
--- a/app-admin/sudo/sudo-1.7.0.ebuild
+++ b/app-admin/sudo/sudo-1.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.7.0.ebuild,v 1.10 2009/02/04 11:42:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.7.0.ebuild,v 1.11 2009/02/23 13:56:55 flameeyes Exp $
inherit eutils pam confutils
@@ -47,6 +47,8 @@ pkg_setup() {
src_unpack() {
unpack ${A}; cd "${S}"
+ epatch "${FILESDIR}/${P}-parallelinstall.patch"
+
# compatability fix.
epatch "${FILESDIR}"/${PN}-skeychallengeargs.diff
@@ -166,7 +168,7 @@ src_compile() {
}
src_install() {
- emake -j1 DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog HISTORY PORTING README TROUBLESHOOTING \
UPGRADE WHATSNEW sample.sudoers sample.syslog.conf