summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-06-14 16:44:33 +0000
committerRichard Yao <ryao@gentoo.org>2012-06-14 16:44:33 +0000
commit7666cf76435cd5bbf611070b56db25ea1c45e7dd (patch)
tree3995d52346c859de7ef160019580f8af794cf626 /app-arch/libarchive
parentAdd app-text/djview to qt mask (diff)
downloadgentoo-2-7666cf76435cd5bbf611070b56db25ea1c45e7dd.tar.gz
gentoo-2-7666cf76435cd5bbf611070b56db25ea1c45e7dd.tar.bz2
gentoo-2-7666cf76435cd5bbf611070b56db25ea1c45e7dd.zip
Apply upstream patch by Naohiro Aota to handle unknown acl types, bug #413865
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/libarchive')
-rw-r--r--app-arch/libarchive/ChangeLog9
-rw-r--r--app-arch/libarchive/files/libarchive-3.0.4-handle-unsupported-acl-types.patch24
-rw-r--r--app-arch/libarchive/libarchive-3.0.4-r1.ebuild (renamed from app-arch/libarchive/libarchive-3.0.4.ebuild)6
3 files changed, 37 insertions, 2 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index 1a0bd9d57392..e22bcc5a0cab 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.123 2012/05/18 18:18:53 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.124 2012/06/14 16:44:33 ryao Exp $
+
+*libarchive-3.0.4-r1 (14 Jun 2012)
+
+ 14 Jun 2012; Richard Yao <ryao@gentoo.org>
+ +files/libarchive-3.0.4-handle-unsupported-acl-types.patch,
+ +libarchive-3.0.4-r1.ebuild, -libarchive-3.0.4.ebuild:
+ Apply upstream patch by Naohiro Aota to handle unknown acl types, bug #413865
18 May 2012; <richard@gentoo.org> libarchive-3.0.3.ebuild:
keyword ~amd64-fbsd
diff --git a/app-arch/libarchive/files/libarchive-3.0.4-handle-unsupported-acl-types.patch b/app-arch/libarchive/files/libarchive-3.0.4-handle-unsupported-acl-types.patch
new file mode 100644
index 000000000000..5bbd5d6e5d9e
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-3.0.4-handle-unsupported-acl-types.patch
@@ -0,0 +1,24 @@
+From d8b9dbd6dac0125957b997c2fe8d246237ec9f94 Mon Sep 17 00:00:00 2001
+From: naota <naota@elisp.net>
+Date: Fri, 25 May 2012 13:03:21 +0900
+Subject: [PATCH] Avoid infinite loop when there's unsupported acl type
+
+---
+ libarchive/archive_read_disk_entry_from_file.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libarchive/archive_read_disk_entry_from_file.c b/libarchive/archive_read_disk_entry_from_file.c
+index 7987fa5..25b1edc 100644
+--- a/libarchive/archive_read_disk_entry_from_file.c
++++ b/libarchive/archive_read_disk_entry_from_file.c
+@@ -584,6 +584,7 @@ static int translate_acl(struct archive_read_disk *a,
+ break;
+ default:
+ /* Skip types that libarchive can't support. */
++ s = acl_get_entry(acl, ACL_NEXT_ENTRY, &acl_entry);
+ continue;
+ }
+
+--
+1.7.10
+
diff --git a/app-arch/libarchive/libarchive-3.0.4.ebuild b/app-arch/libarchive/libarchive-3.0.4-r1.ebuild
index 3c0e829aa729..9d7f0fcafaa0 100644
--- a/app-arch/libarchive/libarchive-3.0.4.ebuild
+++ b/app-arch/libarchive/libarchive-3.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-3.0.4.ebuild,v 1.2 2012/04/26 13:40:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-3.0.4-r1.ebuild,v 1.1 2012/06/14 16:44:33 ryao Exp $
EAPI=4
inherit eutils multilib
@@ -34,6 +34,10 @@ DEPEND="${RDEPEND}
DOCS="NEWS README"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-handle-unsupported-acl-types.patch"
+}
+
src_configure() {
export ac_cv_header_ext2fs_ext2_fs_h=$(usex e2fsprogs) #354923