summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-02-06 16:55:15 +0000
committerJeroen Roovers <jer@gentoo.org>2011-02-06 16:55:15 +0000
commit7002f71eefee6722586c848d1ca1321c88edb9ad (patch)
treef628c1ebe4450ed55170b3ab38ba42a084843b57 /app-arch/sharutils
parentUse virtual/jpeg. (diff)
downloadgentoo-2-7002f71eefee6722586c848d1ca1321c88edb9ad.tar.gz
gentoo-2-7002f71eefee6722586c848d1ca1321c88edb9ad.tar.bz2
gentoo-2-7002f71eefee6722586c848d1ca1321c88edb9ad.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'app-arch/sharutils')
-rw-r--r--app-arch/sharutils/ChangeLog9
-rw-r--r--app-arch/sharutils/sharutils-4.11.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/app-arch/sharutils/ChangeLog b/app-arch/sharutils/ChangeLog
index 10b1f29f7f86..990f9247ed55 100644
--- a/app-arch/sharutils/ChangeLog
+++ b/app-arch/sharutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/sharutils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/ChangeLog,v 1.67 2010/08/30 04:39:35 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/ChangeLog,v 1.68 2011/02/06 16:55:15 jer Exp $
+
+*sharutils-4.11 (06 Feb 2011)
+
+ 06 Feb 2011; Jeroen Roovers <jer@gentoo.org> +sharutils-4.11.ebuild:
+ Version bump.
*sharutils-4.10 (30 Aug 2010)
diff --git a/app-arch/sharutils/sharutils-4.11.ebuild b/app-arch/sharutils/sharutils-4.11.ebuild
new file mode 100644
index 000000000000..993b2cec8d6c
--- /dev/null
+++ b/app-arch/sharutils/sharutils-4.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/sharutils/sharutils-4.11.ebuild,v 1.1 2011/02/06 16:55:15 jer Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="Tools to deal with shar archives"
+HOMEPAGE="http://www.gnu.org/software/sharutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="sys-apps/texinfo
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ strip-linguas -u po
+ econf $(use_enable nls)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}