summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-23 23:54:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-23 23:54:49 +0000
commit3e467d362f5501ef624a54d9db5420b6f7513b65 (patch)
tree075d418c8581821e444cbcba54308b3f1294da99 /app-crypt
parentFix get_libdir typo (diff)
downloadgentoo-2-3e467d362f5501ef624a54d9db5420b6f7513b65.tar.gz
gentoo-2-3e467d362f5501ef624a54d9db5420b6f7513b65.tar.bz2
gentoo-2-3e467d362f5501ef624a54d9db5420b6f7513b65.zip
USE flag qt->qt3/qt4 change
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog6
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2-r2.ebuild12
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2-r3.ebuild10
3 files changed, 16 insertions, 12 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 3cc540ec49c2..e63c3375132b 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.46 2006/06/05 10:38:30 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.47 2006/06/23 23:54:49 cardoe Exp $
+
+ 23 Jun 2006; Doug Goldstein <cardoe@gentoo.org> pinentry-0.7.2-r2.ebuild,
+ pinentry-0.7.2-r3.ebuild:
+ USE flag qt->qt3/qt4 change
05 Jun 2006; Guy Martin <gmsoft@gentoo.org> pinentry-0.7.2-r3.ebuild:
Stable on hppa.
diff --git a/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild b/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild
index 96066eccb1cd..95aa285bb07f 100644
--- a/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild,v 1.9 2006/02/06 10:19:22 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r2.ebuild,v 1.10 2006/06/23 23:54:49 cardoe Exp $
inherit flag-o-matic qt3 multilib
@@ -11,17 +11,17 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
-IUSE="gtk ncurses qt"
+IUSE="gtk ncurses qt3"
DEPEND="gtk? ( =x11-libs/gtk+-2* )
ncurses? ( sys-libs/ncurses )
- qt? ( $(qt_min_version 3.3) )
- !gtk? ( !qt? ( !ncurses? ( sys-libs/ncurses ) ) )"
+ qt3? ( $(qt_min_version 3.3) )
+ !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )"
src_compile() {
local myconf=""
- if ! ( use qt || use gtk || use ncurses )
+ if ! ( use qt3 || use gtk || use ncurses )
then
myconf="--enable-pinentry-curses --enable-fallback-curses"
fi
@@ -36,7 +36,7 @@ src_compile() {
--enable-maintainer-mode \
--disable-pinentry-gtk \
$(use_enable gtk pinentry-gtk2) \
- $(use_enable qt pinentry-qt) \
+ $(use_enable qt3 pinentry-qt) \
$(use_enable ncurses pinentry-curses) \
$(use_enable ncurses fallback-curses) \
${myconf} \
diff --git a/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild b/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild
index f7e11e0ef332..0fe490af990f 100644
--- a/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild,v 1.5 2006/06/05 10:38:30 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r3.ebuild,v 1.6 2006/06/23 23:54:49 cardoe Exp $
inherit flag-o-matic qt3 multilib eutils autotools
@@ -11,11 +11,11 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 hppa ~ia64 ~mips ~ppc ppc64 ~sparc ~x86"
-IUSE="gtk ncurses qt caps"
+IUSE="gtk ncurses qt3 caps"
DEPEND="gtk? ( =x11-libs/gtk+-2* )
ncurses? ( sys-libs/ncurses )
- qt? ( $(qt_min_version 3.3) )
+ qt3? ( $(qt_min_version 3.3) )
!gtk? ( !qt? ( !ncurses? ( sys-libs/ncurses ) ) )
caps? ( sys-libs/libcap )"
@@ -30,7 +30,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if ! ( use qt || use gtk || use ncurses )
+ if ! ( use qt3 || use gtk || use ncurses )
then
myconf="--enable-pinentry-curses --enable-fallback-curses"
fi
@@ -45,7 +45,7 @@ src_compile() {
--enable-maintainer-mode \
--disable-pinentry-gtk \
$(use_enable gtk pinentry-gtk2) \
- $(use_enable qt pinentry-qt) \
+ $(use_enable qt3 pinentry-qt) \
$(use_enable ncurses pinentry-curses) \
$(use_enable ncurses fallback-curses) \
$(use_with caps libcap) \