summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-01 10:02:35 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-01 10:02:35 +0000
commit38a32d123aae2dde04f6aad6fedd6d53ec8d8926 (patch)
treeaa1b8b9e51ac87fd1b28991bbbe7b0691d132cd0 /app-dicts/stardict/stardict-2.2.1.ebuild
parentversion/stable bump (diff)
downloadgentoo-2-38a32d123aae2dde04f6aad6fedd6d53ec8d8926.tar.gz
gentoo-2-38a32d123aae2dde04f6aad6fedd6d53ec8d8926.tar.bz2
gentoo-2-38a32d123aae2dde04f6aad6fedd6d53ec8d8926.zip
version/stable bump
Diffstat (limited to 'app-dicts/stardict/stardict-2.2.1.ebuild')
-rw-r--r--app-dicts/stardict/stardict-2.2.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-dicts/stardict/stardict-2.2.1.ebuild b/app-dicts/stardict/stardict-2.2.1.ebuild
new file mode 100644
index 000000000000..6e625637e8ea
--- /dev/null
+++ b/app-dicts/stardict/stardict-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.2.1.ebuild,v 1.1 2003/07/01 10:02:26 liquidx Exp $
+
+inherit gnome2
+
+# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
+# their indexes seem to be in a different format. So we'll keep them
+# seperate for now.
+
+IUSE=""
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME2 international dictionary supporting fuzzy and glob style matching"
+HOMEPAGE="http://stardict.sourceforge.net/ http://cosoft.org.cn/projects/stardict/"
+SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# when adding keywords, remember to add to stardict.eclass
+KEYWORDS="~x86"
+
+
+DEPEND=">=gnome-base/libbonobo-2.2.0
+ >=gnome-base/libgnome-2.2.0
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/bonobo-activation-2.2.0
+ >=sys-libs/zlib-1.1.4
+ >=gnome-base/gconf-1.2
+ >=dev-libs/popt-1.7
+ >=gnome-base/ORBit2-2.6"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix
+}
+
+src_install() {
+ gnome2_src_install
+ # dictionary index generation files
+ insinto /usr/share/stardict/tools
+ doins ${S}/tools/{dictd2dic,directory2dict,olddic2newdic,oxford2dic,pydict2dict,wquick2dict}
+}
+
+pkg_postinst() {
+ einfo "You will now need to install stardict dictionary files. If"
+ einfo "you have not, execute the below to get a list of dictionaries:"
+ echo
+ einfo " emerge -s stardict-"
+}