summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-10-15 20:20:06 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-10-15 20:20:06 +0000
commitce20dc30c768cfdc65cf4057785f432685ea0119 (patch)
tree0b445f7ea98bfcdb7dd8f334b75eb4ce06bd0b5c /app-editors/gvim/gvim-6.4.ebuild
parentMarked ppc stable for bug #109094. (diff)
downloadgentoo-2-ce20dc30c768cfdc65cf4057785f432685ea0119.tar.gz
gentoo-2-ce20dc30c768cfdc65cf4057785f432685ea0119.tar.bz2
gentoo-2-ce20dc30c768cfdc65cf4057785f432685ea0119.zip
New version. More fstab fixes, bug #108732.
(Portage version: 2.0.53_rc5 three monkeys, ten minutes edition)
Diffstat (limited to 'app-editors/gvim/gvim-6.4.ebuild')
-rw-r--r--app-editors/gvim/gvim-6.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-6.4.ebuild b/app-editors/gvim/gvim-6.4.ebuild
new file mode 100644
index 000000000000..adf64b2228f5
--- /dev/null
+++ b/app-editors/gvim/gvim-6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.4.ebuild,v 1.1 2005/10/15 20:19:34 ciaranm Exp $
+
+inherit vim
+
+VIM_VERSION="6.4"
+VIM_GENTOO_PATCHES="vim-${PV}-gentoo-patches.tar.bz2"
+# VIM_ORG_PATCHES="vim-${PV}-patches.tar.bz2"
+# VIM_RUNTIME_SNAP="vim-runtime-20050809.tar.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+# mirror://gentoo/${VIM_ORG_PATCHES}
+# mirror://gentoo/${VIM_RUNTIME_SNAP}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnome gtk motif nls"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ virtual/x11
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ virtual/xft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? ( motif? ( x11-libs/openmotif ) )"