summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-02-17 13:54:49 +0000
committerUlrich Müller <ulm@gentoo.org>2013-02-17 13:54:49 +0000
commitb09a37f2a8fd1f919152c82421e797a07408d5e2 (patch)
tree7b817fe44cc7873674c217f2661771e25a005887 /app-emacs/pymacs
parentMigrate to distutils-r1. Restrict tests because of the requirement for couchd... (diff)
downloadgentoo-2-b09a37f2a8fd1f919152c82421e797a07408d5e2.tar.gz
gentoo-2-b09a37f2a8fd1f919152c82421e797a07408d5e2.tar.bz2
gentoo-2-b09a37f2a8fd1f919152c82421e797a07408d5e2.zip
Version bump, bug 457942.
(Portage version: 2.1.11.51/cvs/Linux x86_64, signed Manifest commit with key E7BE08CA7DC6EA25)
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/ChangeLog9
-rw-r--r--app-emacs/pymacs/pymacs-0.25.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emacs/pymacs/ChangeLog b/app-emacs/pymacs/ChangeLog
index 6084be9e39e4..3b2608e5c08b 100644
--- a/app-emacs/pymacs/ChangeLog
+++ b/app-emacs/pymacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/pymacs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.55 2011/10/07 20:58:00 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/ChangeLog,v 1.56 2013/02/17 13:54:49 ulm Exp $
+
+*pymacs-0.25 (17 Feb 2013)
+
+ 17 Feb 2013; Ulrich Müller <ulm@gentoo.org> +pymacs-0.25.ebuild:
+ Version bump, bug 457942.
*pymacs-0.24_beta2 (07 Oct 2011)
diff --git a/app-emacs/pymacs/pymacs-0.25.ebuild b/app-emacs/pymacs/pymacs-0.25.ebuild
new file mode 100644
index 000000000000..9843df3827c8
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.25.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/pymacs/pymacs-0.25.ebuild,v 1.1 2013/02/17 13:54:49 ulm Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 elisp vcs-snapshot
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://pymacs.progiciels-bpi.ca/"
+SRC_URI="https://github.com/pinard/Pymacs/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? ( >=dev-python/docutils-0.7
+ virtual/latex-base )"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+python_configure_all() {
+ # pre-process the files but don't run distutils
+ emake PYSETUP=:
+}
+
+src_configure() {
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ elisp-compile pymacs.el || die
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ elisp_src_install
+ dodoc pymacs.rst
+ use doc && dodoc pymacs.pdf
+}