summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-13 19:25:12 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-13 19:25:12 +0000
commite6b9551071d9d332ab32d1b10793feb69025cd8d (patch)
treea24d25e3f8339176c8b29efbbdae077f7cff6a30 /app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild
parent[app-emulation/xen] Drop old. Alternate fix to -Werror, fixes bug 362303, pat... (diff)
downloadgentoo-2-e6b9551071d9d332ab32d1b10793feb69025cd8d.tar.gz
gentoo-2-e6b9551071d9d332ab32d1b10793feb69025cd8d.tar.bz2
gentoo-2-e6b9551071d9d332ab32d1b10793feb69025cd8d.zip
[app-emulation/xen-pvgrub] Use toolchain function instead of calling LD directly, copy fix from bug #384359, fix to invoke correct compiler, copy from bug #383973, patches by Ian Delaney aka idella4
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild')
-rw-r--r--app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild b/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild
index 322ff5e70f89..89bd864e2e58 100644
--- a/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild
+++ b/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild,v 1.2 2011/09/25 01:45:34 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-pvgrub/xen-pvgrub-4.1.1-r1.ebuild,v 1.3 2011/10/13 19:25:12 alexxy Exp $
EAPI="2"
-inherit flag-o-matic eutils multilib
+inherit flag-o-matic eutils multilib toolchain-funcs
XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles"
OCAML_URL=http://caml.inria.fr/pub/distrib
@@ -91,14 +91,16 @@ src_compile() {
append-flags -fno-strict-overflow
fi
- emake -C tools/include || die "prepare libelf headers failed"
+ emake CC=$(tc-getCC) LD=$(tc-getLD) -C tools/include || die "prepare libelf headers failed"
if use x86; then
- emake -j1 XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub || \
+ emake -j1 CC=$(tc-getCC) LD=$(tc-getLD) \
+ XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub || \
die "compile pv-grub_x86_32 failed"
fi
if use amd64; then
- emake -j1 XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub || \
+ emake -j1 CC=$(tc-getCC) LD=$(tc-getLD) \
+ XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub || \
die "compile pv-grub_x86_64 failed"
if use multilib; then
multilib_toolchain_setup x86