summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-05-09 11:47:58 +0000
committerJeroen Roovers <jer@gentoo.org>2011-05-09 11:47:58 +0000
commit9e44ba019da95cdd60a275eedc699d22c86a953c (patch)
tree104963a0595e6bbd11f29a4cac43b7ce1769fb2f /app-forensics
parentVersion bump, use eapi4. Remove old. (diff)
downloadgentoo-2-9e44ba019da95cdd60a275eedc699d22c86a953c.tar.gz
gentoo-2-9e44ba019da95cdd60a275eedc699d22c86a953c.tar.bz2
gentoo-2-9e44ba019da95cdd60a275eedc699d22c86a953c.zip
Version bump thanks to Max Nokhrin (bug #346617).
(Portage version: 2.2.0_alpha32/cvs/Linux i686)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rkhunter/ChangeLog9
-rw-r--r--app-forensics/rkhunter/rkhunter-1.3.8.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/app-forensics/rkhunter/ChangeLog b/app-forensics/rkhunter/ChangeLog
index b98c6dcdd55c..c740c24d4440 100644
--- a/app-forensics/rkhunter/ChangeLog
+++ b/app-forensics/rkhunter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/rkhunter
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.79 2010/07/09 02:26:38 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.80 2011/05/09 11:47:58 jer Exp $
+
+*rkhunter-1.3.8 (09 May 2011)
+
+ 09 May 2011; Jeroen Roovers <jer@gentoo.org> +rkhunter-1.3.8.ebuild:
+ Version bump thanks to Max Nokhrin (bug #346617).
09 Jul 2010; Jeroen Roovers <jer@gentoo.org> rkhunter-1.3.4-r3.ebuild,
rkhunter-1.3.6.ebuild:
diff --git a/app-forensics/rkhunter/rkhunter-1.3.8.ebuild b/app-forensics/rkhunter/rkhunter-1.3.8.ebuild
new file mode 100644
index 000000000000..cb4b2d09cbf7
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.3.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.3.8.ebuild,v 1.1 2011/05/09 11:47:58 jer Exp $
+
+EAPI=2
+
+inherit eutils bash-completion
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof
+ virtual/cron
+"
+
+S="${WORKDIR}/${P}/files"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.conf.patch"
+}
+
+src_install() {
+ # rkhunter requires to be root
+ dosbin ${PN}
+
+ # rkhunter doesn't create it by itself
+ dodir /var/lib/${PN}/tmp
+
+ insinto /etc
+ doins ${PN}.conf || die "failed to install ${PN}.conf"
+
+ exeinto /usr/lib/${PN}/scripts
+ doexe *.pl || die "failed to install scripts"
+
+ insinto /var/lib/${PN}/db
+ doins *.dat || die "failed to install dat files"
+
+ insinto /var/lib/${PN}/db/i18n
+ doins i18n/*
+
+ doman ${PN}.8 || die "doman failed"
+ dodoc ACKNOWLEDGMENTS CHANGELOG FAQ README || die "dodoc failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}-1.3.cron" ${PN} || \
+ die "failed to install cron script"
+
+ dobashcompletion "${FILESDIR}/${PN}.bash-completion"
+}
+
+pkg_postinst() {
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ elog "If you want ${PN} to send mail, you will need to install"
+ elog "virtual/mailx as well."
+ bash-completion_pkg_postinst
+}