summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-25 17:09:52 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-25 17:09:52 +0000
commit6ab66e882eb62353542568b454e34ca97bf5cf7d (patch)
treeb77a76309b84db860cf0400f4f197adee0b3330d /app-i18n/ibus-chewing
parentReadd -Wall as originally intended. (diff)
downloadgentoo-2-6ab66e882eb62353542568b454e34ca97bf5cf7d.tar.gz
gentoo-2-6ab66e882eb62353542568b454e34ca97bf5cf7d.tar.bz2
gentoo-2-6ab66e882eb62353542568b454e34ca97bf5cf7d.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-chewing')
-rw-r--r--app-i18n/ibus-chewing/ChangeLog9
-rw-r--r--app-i18n/ibus-chewing/files/ibus-chewing-1.0.0.20090220-gentoo.patch15
-rw-r--r--app-i18n/ibus-chewing/ibus-chewing-1.0.0.20090220.ebuild44
3 files changed, 67 insertions, 1 deletions
diff --git a/app-i18n/ibus-chewing/ChangeLog b/app-i18n/ibus-chewing/ChangeLog
index d82040f40cf2..24843f4579eb 100644
--- a/app-i18n/ibus-chewing/ChangeLog
+++ b/app-i18n/ibus-chewing/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/ibus-chewing
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-chewing/ChangeLog,v 1.5 2009/02/05 16:15:13 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-chewing/ChangeLog,v 1.6 2009/02/25 17:09:52 matsuu Exp $
+
+*ibus-chewing-1.0.0.20090220 (25 Feb 2009)
+
+ 25 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/ibus-chewing-1.0.0.20090220-gentoo.patch,
+ +ibus-chewing-1.0.0.20090220.ebuild:
+ Version bumped.
05 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-chewing-0.1.1.20080917.ebuild, ibus-chewing-0.1.1.20081023.ebuild:
diff --git a/app-i18n/ibus-chewing/files/ibus-chewing-1.0.0.20090220-gentoo.patch b/app-i18n/ibus-chewing/files/ibus-chewing-1.0.0.20090220-gentoo.patch
new file mode 100644
index 000000000000..265a292db188
--- /dev/null
+++ b/app-i18n/ibus-chewing/files/ibus-chewing-1.0.0.20090220-gentoo.patch
@@ -0,0 +1,15 @@
+diff -Naur ibus-chewing-1.0.0.20090220-Source.orig/CMakeLists.txt ibus-chewing-1.0.0.20090220-Source/CMakeLists.txt
+--- ibus-chewing-1.0.0.20090220-Source.orig/CMakeLists.txt 2009-02-20 15:35:54.000000000 +0900
++++ ibus-chewing-1.0.0.20090220-Source/CMakeLists.txt 2009-02-26 01:53:30.000000000 +0900
+@@ -69,11 +69,6 @@
+ #====================================================================
+ # Files to be install.
+ #
+-SET(MAIN_DOCS AUTHORS README ChangeLog NEWS COPYING)
+-
+-INSTALL(FILES ${MAIN_DOCS}
+- DESTINATION "${PROJECT_DOCDIR}")
+-
+ INSTALL(DIRECTORY icons
+ DESTINATION ${PROJECT_DATADIR})
+
diff --git a/app-i18n/ibus-chewing/ibus-chewing-1.0.0.20090220.ebuild b/app-i18n/ibus-chewing/ibus-chewing-1.0.0.20090220.ebuild
new file mode 100644
index 000000000000..346362a5dcc8
--- /dev/null
+++ b/app-i18n/ibus-chewing/ibus-chewing-1.0.0.20090220.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-chewing/ibus-chewing-1.0.0.20090220.ebuild,v 1.1 2009/02/25 17:09:52 matsuu Exp $
+
+inherit cmake-utils eutils
+
+MY_P="${P}-Source"
+DESCRIPTION="The Chewing IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1
+ >=dev-libs/libchewing-0.3.2
+ >=dev-util/gob-2"
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PRJ_VER_FULL="${PF}"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}