summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-13 01:09:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-13 01:09:53 +0000
commit79ba63de3bcc28985890cf7785910e35e7e926fc (patch)
tree229f1e9c18d6c560b571dcb2f7e1ebbbe942c9ae /app-misc
parentCompile against newest libpng (diff)
downloadgentoo-2-79ba63de3bcc28985890cf7785910e35e7e926fc.tar.gz
gentoo-2-79ba63de3bcc28985890cf7785910e35e7e926fc.tar.bz2
gentoo-2-79ba63de3bcc28985890cf7785910e35e7e926fc.zip
is cvs breaking? libpng compile
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/magicpoint/files/digest-magicpoint-1.09a-r11
-rw-r--r--app-misc/magicpoint/magicpoint-1.09a-r1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/magicpoint/files/digest-magicpoint-1.09a-r1 b/app-misc/magicpoint/files/digest-magicpoint-1.09a-r1
new file mode 100644
index 000000000000..4c185e51ef1f
--- /dev/null
+++ b/app-misc/magicpoint/files/digest-magicpoint-1.09a-r1
@@ -0,0 +1 @@
+MD5 4fc48bd292a7c8b1aab656bf2f0af47d magicpoint-1.09a.tar.gz 816234
diff --git a/app-misc/magicpoint/magicpoint-1.09a-r1.ebuild b/app-misc/magicpoint/magicpoint-1.09a-r1.ebuild
new file mode 100644
index 000000000000..dd040c6a141d
--- /dev/null
+++ b/app-misc/magicpoint/magicpoint-1.09a-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/magicpoint/magicpoint-1.09a-r1.ebuild,v 1.1 2002/04/13 01:09:53 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an X11 based presentation tool"
+SRC_URI="ftp://ftp.mew.org/pub/MagicPoint/${P}.tar.gz"
+HOMEPAGE="http://www.mew.org/mgp/"
+
+DEPEND="virtual/x11
+ gif? ( >=media-libs/libungif-4.0.1 )
+ imlib? ( media-libs/imlib )
+ truetype? ( >=media-libs/freetype-1.3.1 )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+
+ use gif \
+ && myconf="${myconf} --enable-gif" \
+ || myconf="${myconf} --disable-gif"
+
+ use imlib \
+ && myconf="${myconf} --enable-imlib" \
+ || myconf="${myconf} --disable-imlib"
+
+ use truetype \
+ && myconf="${myconf} --enable-freetype" \
+ || myconf="${myconf} --disable-freetype"
+
+ use nls \
+ && myconf="${myconf} --enable-locale" \
+ || myconf="${myconf} --disable-locale"
+
+ export LIBS="-L/usr/lib/ -L/usr/X11R6/lib/ -lX11"
+
+ ./configure \
+ --with-xa \
+ ${myconf} || die
+
+ xmkmf || die
+ make Makefiles || die
+ make clean || die
+ make || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ make \
+ DESTDIR=${D} \
+ DOCHTMLDIR=/usr/share/doc/${P} \
+ MANPATH=/usr/share/man \
+ MANSUFFIX=1 \
+ install.man || die
+
+ dodoc COPYRIGHT* FAQ README* RELNOTES SYNTAX TODO* USAGE*
+}