summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-04-24 19:54:57 +0000
committerTod Neidt <tod@gentoo.org>2002-04-24 19:54:57 +0000
commitc1cd9f83c1f506893273b5a1742ba9daee9acdd5 (patch)
tree9113704b14c5064729d849c7443c91fc9050989f /app-misc
parentReordered month and year in the version number. (diff)
downloadgentoo-2-c1cd9f83c1f506893273b5a1742ba9daee9acdd5.tar.gz
gentoo-2-c1cd9f83c1f506893273b5a1742ba9daee9acdd5.tar.bz2
gentoo-2-c1cd9f83c1f506893273b5a1742ba9daee9acdd5.zip
Fix for bug# 1810. Install tarball supplied etc/xlock.pamd as /etc/pam.d/xlock if 'pam' is in USE. Also, unset setuid root if 'pam' is in USE as the ability to run apps such as this without setuid root is a benefit of using pam. Also, Also changed emake to make as the xlockmore build resets to -j1 anyway and this eleminates the error msg.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/xlockmore/ChangeLog12
-rw-r--r--app-misc/xlockmore/files/digest-xlockmore-5.03-r51
-rw-r--r--app-misc/xlockmore/xlockmore-5.03-r5.ebuild98
3 files changed, 110 insertions, 1 deletions
diff --git a/app-misc/xlockmore/ChangeLog b/app-misc/xlockmore/ChangeLog
index 094e6878dd8e..5e9f384a540f 100644
--- a/app-misc/xlockmore/ChangeLog
+++ b/app-misc/xlockmore/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-misc/xlockmore
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/ChangeLog,v 1.6 2002/04/14 08:40:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/ChangeLog,v 1.7 2002/04/24 19:54:57 tod Exp $
+
+*xlockmore-5.03-r5 (24 Apr 2002)
+
+ 24 Apr 2002; Tod Neidt <tod@gentoo.org> xlockmore-5.03-r5.ebuild :
+
+ Fix for Bug# 1810. Install tarball supplied etc/xlock.pamd
+ as /etc/pam.d/xlock if 'pam' is in USE. Also unset setuid root if
+ 'pam' is in USE as one of the benefits of using pam is not running
+ apps such as this setuid root. Also rolled back emake to make as the
+ xlock build resets to -j1 anyway and this eleminates the error msgs.
*xlockmore-5.03-r4 (14 Apr 2002)
diff --git a/app-misc/xlockmore/files/digest-xlockmore-5.03-r5 b/app-misc/xlockmore/files/digest-xlockmore-5.03-r5
new file mode 100644
index 000000000000..0c8cf283098a
--- /dev/null
+++ b/app-misc/xlockmore/files/digest-xlockmore-5.03-r5
@@ -0,0 +1 @@
+MD5 3f3a30c92e4d241dd81c6059f2724c55 xlockmore-5.03.tar.gz 1730062
diff --git a/app-misc/xlockmore/xlockmore-5.03-r5.ebuild b/app-misc/xlockmore/xlockmore-5.03-r5.ebuild
new file mode 100644
index 000000000000..1ba34f686096
--- /dev/null
+++ b/app-misc/xlockmore/xlockmore-5.03-r5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: system@gentoo.org
+# /space/gentoo/cvsroot/gentoo-x86/app-misc/xlockmore/xlockmore-5.03-r4.ebuild,v 1.1 2002/04/14 08:40:31 seemant Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/${P}.tar.gz"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+DEPEND="virtual/x11 media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( sys-libs/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )"
+ # motif? ( >=x11-libs/openmotif-2.1.30-r1 )
+ # gtk? ( x11-libs/gtk+ )
+
+src_compile() {
+
+ local myconf
+
+ use pam \
+ && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam --enable-xlockrc"
+
+ use nas \
+ || myconf="${myconf} --without-nas"
+
+ use esd \
+ && myconf="${myconf} --with-esound"
+
+ use opengl \
+ || myconf="${myconf} --without-opengl"
+
+ use truetype \
+ || myconf="${myconf} --without-ttf"
+
+ use esd \
+ && myconf="${myconf} --with-esound"
+
+ #use motif || myconf="${myconf} --without-motif"
+ #use gtk || myconf="${myconf} --without-gtk"
+ # sigh... broken configure script and/or makefile...
+ myconf="${myconf} --without-motif --without-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=${prefix}/share/man/man1 \
+ --sharedstatedir=/usr/share/xlockmore \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ #xlock resets to -j1
+ make || die
+
+ # configure script seems to suffer braindamage and doesn't setup
+ # correct makefiles for these, so they are disabled for now until
+ # some kind soul wants to submit a patch ;)
+
+ #if [ "`use gtk`" ] ; then
+ # cd ${S}/xglock
+ # make all || die
+ #fi
+
+ #if [ "`use motif`" ] ; then
+ # cd ${S}/xmlock
+ # make all || die
+ #fi
+
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ xapploaddir=${D}/usr/X11R6/lib/X11/app-defaults \
+ install || die
+
+ #Install pam.d file and unset setuid root
+ if use pam; then
+ insinto /etc/pam.d
+ newins etc/xlock.pamd xlock
+ chmod 111 ${D}/usr/bin/xlock
+ fi
+
+ insinto /usr/share/xlockmore/sounds
+ doins sounds/*
+
+# use motif && doexe ${S}/xmlock/xmlock
+# use gtk && doexe ${S}/xglock/xglock
+
+ dodoc docs/* README
+# use gtk && dodoc xglock/xglockrc xglock/README.xglock
+
+}