summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-19 14:18:09 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-19 14:18:09 +0000
commitdc6fa849b5f01132114bb087f8c0c6c46114bf09 (patch)
treeb5d9fb0ba539a1f8673718e8e51d585e28d26dd2 /app-office/impressive
parentsci-biology/plink: Version BUmp, #510716 (diff)
downloadgentoo-2-dc6fa849b5f01132114bb087f8c0c6c46114bf09.tar.gz
gentoo-2-dc6fa849b5f01132114bb087f8c0c6c46114bf09.tar.bz2
gentoo-2-dc6fa849b5f01132114bb087f8c0c6c46114bf09.zip
app-office/impressive: Version BUmp. #510624
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office/impressive')
-rw-r--r--app-office/impressive/ChangeLog7
-rw-r--r--app-office/impressive/impressive-0.10.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-office/impressive/ChangeLog b/app-office/impressive/ChangeLog
index 82b30ed679c9..40fe3aa63690 100644
--- a/app-office/impressive/ChangeLog
+++ b/app-office/impressive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/impressive
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/ChangeLog,v 1.11 2014/03/06 10:26:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/ChangeLog,v 1.12 2014/05/19 14:18:09 jlec Exp $
+
+*impressive-0.10.5 (19 May 2014)
+
+ 19 May 2014; Justin Lecher <jlec@gentoo.org> +impressive-0.10.5.ebuild:
+ Version BUmp. #510624
06 Mar 2014; Justin Lecher <jlec@gentoo.org> -impressive-0.10.3-r1.ebuild:
Drop old
diff --git a/app-office/impressive/impressive-0.10.5.ebuild b/app-office/impressive/impressive-0.10.5.ebuild
new file mode 100644
index 000000000000..f01b2be2aa65
--- /dev/null
+++ b/app-office/impressive/impressive-0.10.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/impressive/impressive-0.10.5.ebuild,v 1.1 2014/05/19 14:18:09 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ app-text/pdftk
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils
+ x11-apps/xrandr
+ || ( app-text/xpdf app-text/ghostscript-gpl )
+ || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera media-fonts/corefonts )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}.py
+
+ # compatibility symlinks
+ dosym impressive.py /usr/bin/impressive
+ dosym impressive.py /usr/bin/keyjnote
+
+ # docs
+ doman impressive.1
+ dohtml impressive.html
+ dodoc changelog.txt demo.pdf
+}