summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-10-14 11:17:53 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-10-14 11:17:53 +0000
commit2d8b0be792f81baf026f7cb3fe6155f2e2b133d8 (patch)
treeb8fa8d8fc5792d21d0ce6690e8c5a67a7b851049 /app-office/texmacs
parentVersion bump (diff)
downloadgentoo-2-2d8b0be792f81baf026f7cb3fe6155f2e2b133d8.tar.gz
gentoo-2-2d8b0be792f81baf026f7cb3fe6155f2e2b133d8.tar.bz2
gentoo-2-2d8b0be792f81baf026f7cb3fe6155f2e2b133d8.zip
Version bump
(Portage version: 2.2.7/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog7
-rw-r--r--app-office/texmacs/texmacs-1.0.7.20.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 0b7a39f3bff4..890ce74fc175 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmacs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.109 2013/05/01 05:08:23 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.110 2013/10/14 11:17:53 grozin Exp $
+
+*texmacs-1.0.7.20 (14 Oct 2013)
+
+ 14 Oct 2013; Andrey Grozin <grozin@gentoo.org> +texmacs-1.0.7.20.ebuild:
+ Version bump
01 May 2013; Andrey Grozin <grozin@gentoo.org> texmacs-1.0.7.19.ebuild:
Downloading from ftp.texmacs.org works again
diff --git a/app-office/texmacs/texmacs-1.0.7.20.ebuild b/app-office/texmacs/texmacs-1.0.7.20.ebuild
new file mode 100644
index 000000000000..baeb28f37652
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.20.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.20.ebuild,v 1.1 2013/10/14 11:17:53 grozin Exp $
+
+EAPI=4
+
+inherit autotools eutils fdo-mime gnome2-utils
+
+MY_P=${P/tex/TeX}-src
+
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+HOMEPAGE="http://www.texmacs.org/"
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/tmftp/source/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-scheme/guile[deprecated]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ media-libs/freetype
+ x11-libs/libXext
+ x11-apps/xmodmap
+ qt4? ( dev-qt/qtgui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg:2 ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( app-text/aspell )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # respect LDFLAGS, bug #338459
+ epatch "${FILESDIR}"/${PN}-plugins.patch
+
+ # dont update mime and desktop databases and icon cache
+ epatch "${FILESDIR}"/${PN}-updates.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+}
+
+src_install() {
+ default
+ domenu "${FILESDIR}"/TeXmacs.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}