summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-06 22:28:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-06 22:28:26 +0000
commita510c14b64464664647bb512667821ba7fc3d3d9 (patch)
tree635cc7b7ddd83264964ce64667ed7834350a0329 /app-pda
parentSparc stable, security bug #234075 (good for about a week anyway). (diff)
downloadgentoo-2-a510c14b64464664647bb512667821ba7fc3d3d9.tar.gz
gentoo-2-a510c14b64464664647bb512667821ba7fc3d3d9.tar.bz2
gentoo-2-a510c14b64464664647bb512667821ba7fc3d3d9.zip
add patch to fix detection with hal-0.5.11, bug #231678.
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-gentoo-mactel x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/gnome-pilot/ChangeLog8
-rw-r--r--app-pda/gnome-pilot/files/gnome-pilot-2.0.16-hal-0.5.11.patch38
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.16-r1.ebuild65
3 files changed, 110 insertions, 1 deletions
diff --git a/app-pda/gnome-pilot/ChangeLog b/app-pda/gnome-pilot/ChangeLog
index 2e83560fc8e1..45a399cac41e 100644
--- a/app-pda/gnome-pilot/ChangeLog
+++ b/app-pda/gnome-pilot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/gnome-pilot
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.46 2008/08/01 19:16:04 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.47 2008/08/06 22:28:25 eva Exp $
+
+*gnome-pilot-2.0.16-r1 (06 Aug 2008)
+
+ 06 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gnome-pilot-2.0.16-hal-0.5.11.patch, +gnome-pilot-2.0.16-r1.ebuild:
+ add patch to fix detection with hal-0.5.11, bug #231678.
01 Aug 2008; nixnut <nixnut@gentoo.org> gnome-pilot-2.0.16.ebuild:
Stable on ppc wrt bug 230067
diff --git a/app-pda/gnome-pilot/files/gnome-pilot-2.0.16-hal-0.5.11.patch b/app-pda/gnome-pilot/files/gnome-pilot-2.0.16-hal-0.5.11.patch
new file mode 100644
index 000000000000..df0042899780
--- /dev/null
+++ b/app-pda/gnome-pilot/files/gnome-pilot-2.0.16-hal-0.5.11.patch
@@ -0,0 +1,38 @@
+--- gpilotd/gpilotd.c-old 2008-07-13 21:52:04.000000000 +1000
++++ gpilotd/gpilotd.c 2008-07-13 21:53:30.000000000 +1000
+@@ -1079,7 +1079,7 @@
+ hal_device_added (LibHalContext *ctx, const char *udi)
+ {
+ gboolean visor_net = FALSE;
+- char *bus, *match_str;
++ char *bus, *platform, *match_str;
+ int vendor_id, product_id, i;
+ GPilotDevice *device;
+ DBusError error;
+@@ -1090,15 +1090,23 @@
+
+ load_devices_xml ();
+
+- /* HAL match rule: we look for info.bus == 'usb_device'
++ /* HAL match rule: we look for pda.platform == 'palm'
++ * (or the legacy info.bus == 'usb_device')
+ * and then try to match the usb_device.product_id and usb_device.vendor_id
+ * against the list in devices.xml.
+ */
+- if (!(bus = libhal_device_get_property_string (hal_ctx, udi, "info.bus", NULL)))
++ if (platform = libhal_device_get_property_string (hal_ctx, udi, "pda.platform", NULL)) {
++ if (strcmp (platform, "palm") != 0) {
++ libhal_free_string (platform);
+ return;
+- if (strcmp (bus, "usb_device") != 0) {
++ }
++ } else if (bus = libhal_device_get_property_string (hal_ctx, udi, "info.bus", NULL)) {
++ if (strcmp (bus, "usb_device") != 0) {
+ libhal_free_string (bus);
+ return;
++ }
++ } else {
++ return;
+ }
+
+ dbus_error_init (&error);
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.16-r1.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.16-r1.ebuild
new file mode 100644
index 000000000000..995805169307
--- /dev/null
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.16-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.16-r1.ebuild,v 1.1 2008/08/06 22:28:25 eva Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="Gnome Palm Pilot and Palm OS Device Syncing Library"
+HOMEPAGE="http://live.gnome.org/GnomePilot"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="hal"
+
+RDEPEND=">=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libglade-2.0.0
+ >=gnome-base/orbit-2.6.0
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/gnome-panel-2.0
+ >=gnome-base/gconf-2.0
+ dev-libs/libxml2
+ >=app-pda/pilot-link-0.11.7
+ hal? (
+ dev-libs/dbus-glib
+ >=sys-apps/hal-0.5.4
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/gob-2.0.5
+ >=dev-lang/perl-5.6.0
+ dev-util/intltool"
+
+DOCS="AUTHORS COPYING* ChangeLog README NEWS"
+SCROLLKEEPER_UPDATE="0"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-usb
+ --enable-network
+ --enable-pilotlinktest
+ $(use_with hal)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ echo "libgpilotdCM/gnome-pilot-conduit-management.c" >> po/POTFILES.in
+
+ # Fix --as-needed
+ epatch "${FILESDIR}/${PN}-2.0.15-as-needed.patch"
+
+ # Fix use with hal-0.5.11
+ epatch "${FILESDIR}/${P}-hal-0.5.11.patch"
+
+ eautoreconf
+ intltoolize --force || die
+}
+
+pkg_postinst() {
+ if ! built_with_use app-pda/pilot-link bluetooth; then
+ elog "if you want bluetooth support, please rebuild app-pda/pilot-link"
+ elog "echo 'app-pda/pilot-link bluetooth >> /etc/portage/package.use"
+ fi
+}