summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-01-28 17:52:38 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-01-28 17:52:38 +0000
commita2694e8ab7b67db8bfa391c804ca4e2936022b93 (patch)
tree71d71c1a702c0c8c6b7c2d18bed762eaa0b4ecda /app-portage
parentMasked >=app-arch/rpm-4.4.7-r3: net-snmp and sussen are broken with it, bug #... (diff)
downloadgentoo-2-a2694e8ab7b67db8bfa391c804ca4e2936022b93.tar.gz
gentoo-2-a2694e8ab7b67db8bfa391c804ca4e2936022b93.tar.bz2
gentoo-2-a2694e8ab7b67db8bfa391c804ca4e2936022b93.zip
Warn on missing subversion package (#200395).
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/layman/ChangeLog9
-rw-r--r--app-portage/layman/files/digest-layman-1.1.1-r13
-rw-r--r--app-portage/layman/layman-1.1.1-r1.ebuild84
3 files changed, 94 insertions, 2 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index 92486ec50e44..bec85dc01d1a 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/layman
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.54 2007/11/15 07:16:23 wrobel Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.55 2008/01/28 17:52:37 wrobel Exp $
+
+*layman-1.1.1-r1 (28 Jan 2008)
+
+ 28 Jan 2008; Gunnar Wrobel <wrobel@gentoo.org> +layman-1.1.1-r1.ebuild:
+ Warn on missing subversion package (#200395).
15 Nov 2007; <wrobel@gentoo.org> layman-1.0.6.ebuild,
layman-1.0.10.ebuild, layman-1.1.1.ebuild:
diff --git a/app-portage/layman/files/digest-layman-1.1.1-r1 b/app-portage/layman/files/digest-layman-1.1.1-r1
new file mode 100644
index 000000000000..2be0c50e0d7b
--- /dev/null
+++ b/app-portage/layman/files/digest-layman-1.1.1-r1
@@ -0,0 +1,3 @@
+MD5 b63ef0a3276f055a071718afd302239f layman-1.1.1.tar.gz 46122
+RMD160 ef0277455acef5963780dc83c9dd7a24a828d2dd layman-1.1.1.tar.gz 46122
+SHA256 725cf36a5b728dfde707dad3d9d2045b282586021de53518daeb2a6a67b61f2b layman-1.1.1.tar.gz 46122
diff --git a/app-portage/layman/layman-1.1.1-r1.ebuild b/app-portage/layman/layman-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..a861eaf5057b
--- /dev/null
+++ b/app-portage/layman/layman-1.1.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-1.1.1-r1.ebuild,v 1.1 2008/01/28 17:52:37 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="A python script for retrieving gentoo overlays."
+HOMEPAGE="http://layman.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-util/subversion )"
+RDEPEND=""
+
+pkg_setup() {
+ if has_version dev-util/subversion && \
+ (! built_with_use --missing true dev-util/subversion webdav || built_with_use --missing false dev-util/subversion nowebdav); then
+ eerror "You must rebuild your Subversion with support for WebDAV."
+ die "You must rebuild your Subversion with support for WebDAV"
+ fi
+ if ! has_version dev-util/subversion; then
+ ewarn "You do not have dev-util/subversion installed!"
+ ewarn "While layman does not exactly depend on this"
+ ewarn "version control system you should note that"
+ ewarn "most available overlays are offered via"
+ ewarn "dev-util/subversion. If you do not install it"
+ ewarn "you will be unable to use these overlays."
+ ewarn
+ fi
+}
+
+src_install() {
+
+ distutils_src_install
+
+ dodir /etc/layman
+
+ sed -i -e 's/^nocheck : no/nocheck : yes/' etc/layman.cfg
+ cp etc/* "${D}"/etc/layman/
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+}
+
+src_test() {
+ einfo "Running layman doctests..."
+ echo
+ if ! PYTHONPATH="." ${python} layman/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+}
+
+pkg_postinst() {
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo "layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ elog "Select an overlay and add it using"
+ einfo
+ elog "layman -a overlay-name"
+ einfo
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog "source /usr/portage/local/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ einfo
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+ epause 5
+}