summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-12-21 12:16:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-12-21 12:16:18 +0000
commit66667c3ad0e3e85afa210055486cf1cc38048e7d (patch)
treef8e52a9b2313adb8489e923ad5b5b84bb941467d /app-text/evince
parentrm old (diff)
downloadgentoo-2-66667c3ad0e3e85afa210055486cf1cc38048e7d.tar.gz
gentoo-2-66667c3ad0e3e85afa210055486cf1cc38048e7d.tar.bz2
gentoo-2-66667c3ad0e3e85afa210055486cf1cc38048e7d.zip
Version bump for Gnome 3.14.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog8
-rw-r--r--app-text/evince/evince-3.14.1.ebuild103
-rw-r--r--app-text/evince/files/evince-3.14.0-non-bash-support.patch28
3 files changed, 138 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index b0602cf52fe6..74fe429cfcc1 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/evince
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.278 2014/12/19 14:42:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.279 2014/12/21 12:16:18 eva Exp $
+
+*evince-3.14.1 (21 Dec 2014)
+
+ 21 Dec 2014; Gilles Dartiguelongue <eva@gentoo.org> +evince-3.14.1.ebuild,
+ +files/evince-3.14.0-non-bash-support.patch:
+ Version bump for Gnome 3.14.
*evince-3.12.2-r1 (19 Dec 2014)
diff --git a/app-text/evince/evince-3.14.1.ebuild b/app-text/evince/evince-3.14.1.ebuild
new file mode 100644
index 000000000000..b564f40822d5
--- /dev/null
+++ b/app-text/evince/evince-3.14.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.14.1.ebuild,v 1.1 2014/12/21 12:16:18 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
+SLOT="0/evd3.4-evv3.3"
+IUSE="debug djvu dvi gnome +introspection libsecret nautilus +postscript t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+# not mature enough
+# atk used in libview
+# gdk-pixbuf used all over the place
+# libX11 used for totem-screensaver
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib:=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.14:3[introspection?]
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/cairo-1.10:=
+ >=app-text/poppler-0.24:=[cairo]
+ djvu? ( >=app-text/djvu-3.5.17:= )
+ dvi? (
+ virtual/tex-base
+ dev-libs/kpathsea:=
+ t1lib? ( >=media-libs/t1lib-5:= ) )
+ gnome? ( gnome-base/gnome-desktop:3 )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ libsecret? ( >=app-crypt/libsecret-0.5 )
+ nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
+ postscript? ( >=app-text/libspectre-0.2:= )
+ tiff? ( >=media-libs/tiff-3.6:0= )
+ xps? ( >=app-text/libgxps-0.2.1:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg
+ || (
+ >=x11-themes/adwaita-icon-theme-2.17.1
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
+# Releases: http://people.redhat.com/zcerza/dogtail/releases/
+RESTRICT="test"
+
+src_prepare() {
+ # Fix build with non-bash /bin/sh, see bug #526410
+ epatch "${FILESDIR}"/${PN}-3.14.0-non-bash-support.patch
+
+ eautoreconf
+ gnome2_src_prepare
+
+ # Do not depend on adwaita-icon-theme, bug #326855, #391859
+ sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
+ -i configure || die "sed failed"
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-tests \
+ --enable-pdf \
+ --enable-comics \
+ --enable-thumbnailer \
+ --with-platform=gnome \
+ --enable-dbus \
+ --enable-browser-plugin \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_with libsecret keyring) \
+ $(use_enable gnome libgnome-desktop) \
+ $(use_enable introspection) \
+ $(use_enable nautilus) \
+ $(use_enable postscript ps) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps) \
+ BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
+ ITSTOOL=$(type -P true)
+}
diff --git a/app-text/evince/files/evince-3.14.0-non-bash-support.patch b/app-text/evince/files/evince-3.14.0-non-bash-support.patch
new file mode 100644
index 000000000000..979d1860da65
--- /dev/null
+++ b/app-text/evince/files/evince-3.14.0-non-bash-support.patch
@@ -0,0 +1,28 @@
+From 59daf398bc0f1d7895eee3a776b33a9c9310ad21 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Sun, 26 Oct 2014 23:54:47 +0300
+Subject: configure.ac: workaround quoting issues
+
+BROWSER_PLUGIN_DIR variable substitution is not portable. In particular
+it does not work in dash. Replace it with conditional.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=739226
+
+diff --git a/configure.ac b/configure.ac
+index 56bf93c..dd4bcab 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -455,7 +455,9 @@ AC_ARG_ENABLE([browser-plugin],
+ if test x$enable_browser_plugin = "xyes" ; then
+ PKG_CHECK_MODULES([BROWSER_PLUGIN],[gtk+-3.0 >= $GTK_REQUIRED gthread-2.0 gio-2.0 >= $GLIB_REQUIRED])
+
+- BROWSER_PLUGIN_DIR="${BROWSER_PLUGIN_DIR:-"\${libdir}/mozilla/plugins"}"
++ if test -z "${BROWSER_PLUGIN_DIR}"; then
++ BROWSER_PLUGIN_DIR="\${libdir}/mozilla/plugins"
++ fi
+ AC_ARG_VAR([BROWSER_PLUGIN_DIR],[Where to install the plugin to])
+ fi
+
+--
+cgit v0.10.1
+