summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-23 11:19:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-23 11:19:26 +0000
commit26ab89fbc59ebe45a92744359defcacf17cca4b2 (patch)
treefc7004da2a0c9c8fd24af60a4f958bbf06b0caeb /app-text
parentBased on 3.0.7 + genpatches-3.0-8 + grsecurity-2.2.2-3.0.7-201110200052 (diff)
downloadgentoo-2-26ab89fbc59ebe45a92744359defcacf17cca4b2.tar.gz
gentoo-2-26ab89fbc59ebe45a92744359defcacf17cca4b2.tar.bz2
gentoo-2-26ab89fbc59ebe45a92744359defcacf17cca4b2.zip
Update the ebuild not to ship .la and .a archives, punt the overshadowed version.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rarian/ChangeLog9
-rw-r--r--app-text/rarian/rarian-0.8.1-r1.ebuild35
-rw-r--r--app-text/rarian/rarian-0.8.1.ebuild37
3 files changed, 26 insertions, 55 deletions
diff --git a/app-text/rarian/ChangeLog b/app-text/rarian/ChangeLog
index 563df0f15f21..ea32c24b50a4 100644
--- a/app-text/rarian/ChangeLog
+++ b/app-text/rarian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/rarian
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/ChangeLog,v 1.50 2010/09/11 18:26:29 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/ChangeLog,v 1.51 2011/10/23 11:19:26 scarabeus Exp $
+
+ 23 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> -rarian-0.8.1.ebuild,
+ rarian-0.8.1-r1.ebuild:
+ Update the ebuild not to ship .la and .a archives, punt the overshadowed
+ version.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> rarian-0.8.1-r1.ebuild:
Marked ppc for bug #324077.
diff --git a/app-text/rarian/rarian-0.8.1-r1.ebuild b/app-text/rarian/rarian-0.8.1-r1.ebuild
index 4eccb8e36eea..5a5f9d5f66f0 100644
--- a/app-text/rarian/rarian-0.8.1-r1.ebuild
+++ b/app-text/rarian/rarian-0.8.1-r1.ebuild
@@ -1,31 +1,27 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.8.1-r1.ebuild,v 1.9 2010/09/11 18:26:29 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.8.1-r1.ebuild,v 1.10 2011/10/23 11:19:26 scarabeus Exp $
-inherit eutils gnome2
+EAPI=4
+
+inherit eutils
DESCRIPTION="A documentation metadata library"
-HOMEPAGE="http://www.freedesktop.org"
+HOMEPAGE="http://rarian.freedesktop.org/"
+SRC_URI="http://${PN}.freedesktop.org/Releases/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
+IUSE="static-libs"
RDEPEND="dev-libs/libxslt"
DEPEND="${RDEPEND}
!<app-text/scrollkeeper-9999"
-DOCS="ChangeLog NEWS README"
-
-GCONF=""
-
-src_unpack() {
- # You cannot run src_unpack from gnome2; it will break the install by
- # calling gnome2_omf_fix
- unpack ${A}
- cd "${S}"
+DOCS=( ChangeLog NEWS README )
+src_prepare() {
# Fix uri of omf files produced by rarian-sk-preinstall, see bug #302900
epatch "${FILESDIR}/${P}-fix-old-doc.patch"
@@ -35,6 +31,13 @@ src_unpack() {
elibtoolize ${ELTCONF}
}
-src_compile() {
- gnome2_src_compile --localstatedir=/var
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
}
diff --git a/app-text/rarian/rarian-0.8.1.ebuild b/app-text/rarian/rarian-0.8.1.ebuild
deleted file mode 100644
index fa0d60fc84bb..000000000000
--- a/app-text/rarian/rarian-0.8.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.8.1.ebuild,v 1.12 2010/07/20 15:07:11 jer Exp $
-
-inherit eutils gnome2
-
-DESCRIPTION="A documentation metadata library"
-HOMEPAGE="http://www.freedesktop.org"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="dev-libs/libxslt"
-DEPEND="${RDEPEND}
- !<app-text/scrollkeeper-9999"
-
-DOCS="ChangeLog NEWS README"
-
-GCONF=""
-
-src_unpack() {
- # You cannot run src_unpack from gnome2; it will break the install by
- # calling gnome2_omf_fix
- unpack ${A}
- cd "${S}"
-
- # remove unneeded line, bug #240564
- sed "s/ (foreign dist-bzip2 dist-gzip)//" -i configure || die "sed failed"
-
- elibtoolize ${ELTCONF}
-}
-
-src_compile() {
- gnome2_src_compile --localstatedir=/var
-}