summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-09-25 17:37:46 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-09-25 17:37:46 +0000
commit8612f5e331fd8d6f99a082c06cf508be88ea6ebe (patch)
tree2b6ad06cac434fb575f867f9b8429cc113e54e90 /dev-db/pgadmin3
parentEbuild for jsoup-1.7.2 - java html parsing library (diff)
downloadgentoo-2-8612f5e331fd8d6f99a082c06cf508be88ea6ebe.tar.gz
gentoo-2-8612f5e331fd8d6f99a082c06cf508be88ea6ebe.tar.bz2
gentoo-2-8612f5e331fd8d6f99a082c06cf508be88ea6ebe.zip
Version bump fixes bug 485696 and includes patch from bug 472554. pgadmin3-desktop.patch fixes bug 458172.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog9
-rw-r--r--dev-db/pgadmin3/files/pgadmin3-desktop.patch13
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.18.0.ebuild59
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 175aae689ad3..7b1c9add4d0d 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.93 2013/02/27 00:42:41 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.94 2013/09/25 17:37:46 titanofold Exp $
+
+*pgadmin3-1.18.0 (25 Sep 2013)
+
+ 25 Sep 2013; Aaron W. Swenson <titanofold@gentoo.org>
+ +files/pgadmin3-desktop.patch, +pgadmin3-1.18.0.ebuild:
+ Version bump fixes bug 485696 and includes patch from bug 472554.
+ pgadmin3-desktop.patch fixes bug 458172.
27 Feb 2013; Aaron W. Swenson <titanofold@gentoo.org>
-pgadmin3-1.14.2.ebuild, -pgadmin3-1.14.3.ebuild, -pgadmin3-1.16.0.ebuild:
diff --git a/dev-db/pgadmin3/files/pgadmin3-desktop.patch b/dev-db/pgadmin3/files/pgadmin3-desktop.patch
new file mode 100644
index 000000000000..471a78a7807c
--- /dev/null
+++ b/dev-db/pgadmin3/files/pgadmin3-desktop.patch
@@ -0,0 +1,13 @@
+diff -Naruw a/pkg/pgadmin3.desktop b/pkg/pgadmin3.desktop
+--- a/pkg/pgadmin3.desktop 2013-02-22 17:21:19.000000000 +0000
++++ b/pkg/pgadmin3.desktop 2013-09-25 14:34:27.717913730 +0000
+@@ -4,7 +4,7 @@
+ Exec=/usr/bin/pgadmin3
+ Icon=/usr/share/pgadmin3/pgAdmin3.png
+ Type=Application
+-Categories=Application;Development;
+-MimeType=text/html
++Categories=Development;
++MimeType=text/html;
+ DocPath=/usr/share/pgadmin3/docs/en_US/index.html
+ Comment=PostgreSQL Tools
diff --git a/dev-db/pgadmin3/pgadmin3-1.18.0.ebuild b/dev-db/pgadmin3/pgadmin3-1.18.0.ebuild
new file mode 100644
index 000000000000..6d3a88671d2b
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.18.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.18.0.ebuild,v 1.1 2013/09/25 17:37:46 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug +databasedesigner"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/pgadmin3-desktop.patch"
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug) \
+ $(use_enable databasedesigner)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}