summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-08-02 08:33:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-08-02 08:33:01 +0000
commit8f4e23e72d9d38c5ef4fc9b820ca7fb5f31bd3d6 (patch)
tree85144fd75bc77806f50172b489a9954ac108b24f /dev-haskell/ghc-paths
parentremove unused license (diff)
downloadgentoo-2-8f4e23e72d9d38c5ef4fc9b820ca7fb5f31bd3d6.tar.gz
gentoo-2-8f4e23e72d9d38c5ef4fc9b820ca7fb5f31bd3d6.tar.bz2
gentoo-2-8f4e23e72d9d38c5ef4fc9b820ca7fb5f31bd3d6.zip
Version bump.
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/ghc-paths')
-rw-r--r--dev-haskell/ghc-paths/ChangeLog10
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-haskell/ghc-paths/ChangeLog b/dev-haskell/ghc-paths/ChangeLog
index 71ec5bba7370..41366ad8c2ca 100644
--- a/dev-haskell/ghc-paths/ChangeLog
+++ b/dev-haskell/ghc-paths/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/ghc-paths
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ChangeLog,v 1.3 2010/07/17 12:41:26 slyfox Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ChangeLog,v 1.4 2011/08/02 08:33:01 slyfox Exp $
+
+*ghc-paths-0.1.0.8 (02 Aug 2011)
+
+ 02 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ +ghc-paths-0.1.0.8.ebuild:
+ Version bump.
17 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org>
ghc-paths-0.1.0.6.ebuild:
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild
new file mode 100644
index 000000000000..026280a5aba7
--- /dev/null
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/ghc-paths/ghc-paths-0.1.0.8.ebuild,v 1.1 2011/08/02 08:33:01 slyfox Exp $
+
+EAPI="3"
+
+# haddock feature is explicitely disabled, as this library can be used as haddock depend
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Knowledge of GHC's installation directories"
+HOMEPAGE="http://hackage.haskell.org/package/ghc-paths"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ # ghc-patch it has awfully unportable (across cabal versions) ghc detection code
+ # but in gentoo we install it to fixed patch, so remove Setup.hs detection code
+ cabal-mksetup
+
+ # and use gentoo's hardcoded one:
+ # a few things we need to replace, and example values
+ # GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010
+ # GHC_PATHS_DOCDIR /usr/share/doc/ghc-6.12.0.20091010/html
+ # GHC_PATHS_GHC_PKG /usr/bin/ghc-pkg
+ # GHC_PATHS_GHC /usr/bin/ghc (be careful: GHC_PATHS_GHC is a substring of GHC_PATHS_GHC_PKG)
+
+ cat >"${S}/GHC/Paths.hs" <<EOF
+module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
+
+libdir, docdir, ghc, ghc_pkg :: FilePath
+
+libdir = "$(ghc-libdir)"
+docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
+
+ghc = "$(ghc-getghc)"
+ghc_pkg = "$(ghc-getghcpkg)"
+EOF
+}