summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-05-12 15:53:10 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-05-12 15:53:10 +0000
commit4581a5e0abaddcf7746c0baa1ded6277467b5f65 (patch)
tree91f0660abb0c7807f8d105de17942253ab8ad45e /dev-haskell
parentRe-enable alut package and add hack for ia64 (diff)
downloadgentoo-2-4581a5e0abaddcf7746c0baa1ded6277467b5f65.tar.gz
gentoo-2-4581a5e0abaddcf7746c0baa1ded6277467b5f65.tar.bz2
gentoo-2-4581a5e0abaddcf7746c0baa1ded6277467b5f65.zip
New version
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hmake/ChangeLog7
-rw-r--r--dev-haskell/hmake/files/digest-hmake-3.113
-rw-r--r--dev-haskell/hmake/hmake-3.11.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-haskell/hmake/ChangeLog b/dev-haskell/hmake/ChangeLog
index 15f43d02e6f3..815325a863fc 100644
--- a/dev-haskell/hmake/ChangeLog
+++ b/dev-haskell/hmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hmake
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.21 2006/03/16 14:13:49 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.22 2006/05/12 15:53:10 dcoutts Exp $
+
+*hmake-3.11 (12 May 2006)
+
+ 12 May 2006; Duncan Coutts <dcoutts@gentoo.org> +hmake-3.11.ebuild:
+ New version
16 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> hmake-3.10.ebuild:
QA fix; Add eutils to inherit.
diff --git a/dev-haskell/hmake/files/digest-hmake-3.11 b/dev-haskell/hmake/files/digest-hmake-3.11
new file mode 100644
index 000000000000..5fbe189efe35
--- /dev/null
+++ b/dev-haskell/hmake/files/digest-hmake-3.11
@@ -0,0 +1,3 @@
+MD5 643c639048ba894d66ed88cc1f0dc239 hmake-3.11.tar.gz 104443
+RMD160 9027f4bb87b7b825ff5ef05dc735e95a234c438a hmake-3.11.tar.gz 104443
+SHA256 2a120adea7c5cb246d91ba3d8f7be858c3ba184c5f638e316f24271484c64720 hmake-3.11.tar.gz 104443
diff --git a/dev-haskell/hmake/hmake-3.11.ebuild b/dev-haskell/hmake/hmake-3.11.ebuild
new file mode 100644
index 000000000000..5b7b27e2809f
--- /dev/null
+++ b/dev-haskell/hmake/hmake-3.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.1 2006/05/12 15:53:10 dcoutts Exp $
+
+inherit base eutils fixheadtails
+
+DESCRIPTION="a make tool for Haskell programs"
+HOMEPAGE="http://www.haskell.org/hmake/"
+SRC_URI="http://www.haskell.org/hmake/${P}.tar.gz"
+
+LICENSE="nhc98"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/ghc
+ sys-libs/readline
+ >=sys-apps/sandbox-1.2.12"
+RDEPEND="virtual/ghc
+ sys-libs/readline"
+
+# sandbox dependency due to bug #97441, #101433
+
+# if using readline, hmake depends also on ncurses; but
+# readline already has this dependency
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix all head/tail declarations
+ sed -i 's/tail -1/tail -n 1/' src/hmake/MkConfig.hs
+ # the line above prevents current fixheadtails.eclass from doing nonsense;
+ # double space before -n is significant
+ ht_fix_all
+}
+
+src_compile() {
+ # package uses non-standard configure, therefore econf does
+ # not work ...
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man/man1 \
+ --buildwith=ghc \
+ || die "./configure failed"
+
+ # emake tested; parallel make does not work
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dohtml docs/hmake/*
+}