summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-12-14 13:08:17 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-12-14 13:08:17 +0000
commit4b88475ec4198da7877d1580957c2f51071fd46c (patch)
tree14a7b256c9e95a56c8b563cdd0a19b4f8a25e055 /dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild
parentStable for x86, wrt bug #447230 (diff)
downloadgentoo-2-4b88475ec4198da7877d1580957c2f51071fd46c.tar.gz
gentoo-2-4b88475ec4198da7877d1580957c2f51071fd46c.tar.bz2
gentoo-2-4b88475ec4198da7877d1580957c2f51071fd46c.zip
Respect LDFLAGS. #355057
Integrate prefix changes by Benda Xu <heroxbd@gentoo.org>. #416373 Stop using xargs, drop userland_GNU from IUSE and the dependency on findutils. Allow eselect-java be used instead of eselect-ecj. EAPI bump, cleanup, add missing die. Use same launcher for all slots, update rational for gcc-config lookup. (Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 3C5CF75A)
Diffstat (limited to 'dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild')
-rw-r--r--dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild b/dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild
new file mode 100644
index 000000000000..87ed21a476c7
--- /dev/null
+++ b/dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ecj-gcj/ecj-gcj-3.6-r1.ebuild,v 1.1 2012/12/14 13:08:17 sera Exp $
+
+EAPI=5
+
+inherit java-pkg-2 prefix toolchain-funcs
+
+MY_PN="ecj"
+DMF="R-${PV}-201006080911"
+
+DESCRIPTION="A subset of Eclipse Compiler for Java compiled by gcj, serving as javac in gcj-jdk"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF}/${MY_PN}src-${PV}.zip"
+
+LICENSE="EPL-1.0"
+SLOT="3.6"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+native"
+
+COMMON_DEPEND="
+ sys-devel/gcc[gcj]
+ || ( app-admin/eselect-java >=app-admin/eselect-ecj-0.6 )"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ !dev-java/eclipse-ecj:3.5[gcj]"
+
+S="${WORKDIR}"
+
+# for compatibility with java eclass functions
+JAVA_PKG_WANT_SOURCE=1.4
+JAVA_PKG_WANT_TARGET=1.4
+
+MY_PS="${MY_PN}-${SLOT}"
+
+java_prepare() {
+ # We don't need the ant adapter here
+ rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -fr org/eclipse/jdt/internal/antadapter || die
+
+ # upstream build.xml excludes this
+ rm -f META-INF/eclipse.inf || die
+
+ # these java6 specific classes cannot compile with ecj
+ rm -fr org/eclipse/jdt/internal/compiler/{apt,tool}/ || die
+}
+
+src_compile() {
+ local javac_opts javac java jar
+
+ local gccbin=$(gcc-config -B)
+ local gccver=$(gcc-fullversion)
+
+ local gcj="${gccbin}/gcj"
+ javac="${gcj} -C --encoding=ISO-8859-1"
+ jar="${gccbin}/gjar"
+ java="${gccbin}/gij"
+
+ mkdir -p bootstrap || die
+ cp -pPR org bootstrap || die
+ cd "${S}/bootstrap" || die
+
+ einfo "bootstrapping ${MY_PN} with ${javac} ..."
+ ${javac} ${javac_opts} $(find org/ -name '*.java') || die
+ find org/ \( -name '*.class' -o -name '*.properties' -o -name '*.rsc' \) \
+ -exec ${jar} cf ${MY_PN}.jar {} + || die
+
+ cd "${S}" || die
+
+ einfo "building ${MY_PN} with bootstrapped ${MY_PN} ..."
+ ${java} -classpath bootstrap/${MY_PN}.jar \
+ org.eclipse.jdt.internal.compiler.batch.Main \
+ ${javac_opts} -nowarn org || die
+ find org/ \( -name '*.class' -o -name '*.properties' -o -name '*.rsc' \) \
+ -exec ${jar} cf ${MY_PN}.jar {} + || die
+
+ if use native; then
+ einfo "Building native ${MY_PS} library, patience needed ..."
+ ${gcj} ${CFLAGS} ${LDFLAGS} -findirect-dispatch -shared -fPIC -Wl,-Bsymbolic \
+ -o ${MY_PS}.so ${MY_PN}.jar || die
+ fi
+}
+
+src_install() {
+ java-pkg_dojar ${MY_PN}.jar
+
+ sed -e "s|@SLOT@|${SLOT}|" \
+ "${FILESDIR}/${PN}.in" \
+ > "${T}"/${PN}-${SLOT} || die
+ eprefixify "${T}/${PN}-${SLOT}"
+ dobin "${T}/${PN}-${SLOT}"
+
+ use native && dolib.so ${MY_PS}.so
+}
+
+pkg_postinst() {
+ if use native; then
+ $(gcc-config -B)/gcj-dbtool -a $(gcj-dbtool -p) \
+ "${EPREFIX}"/usr/share/${PN}-${SLOT}/lib/ecj.jar \
+ "${EPREFIX}"/usr/$(get_libdir)/${MY_PN}-${SLOT}.so
+ fi
+
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ${PN}-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}