summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-05-20 21:23:08 +0000
committerAnant Narayanan <anant@gentoo.org>2007-05-20 21:23:08 +0000
commit8ff7a15a23388f2fe9935a27e6ea2fa8c803ff07 (patch)
tree282f34cb855fa8f460b6084a1fea52476cc07999 /dev-lang/dmd-bin
parentVersion bump (diff)
downloadgentoo-2-8ff7a15a23388f2fe9935a27e6ea2fa8c803ff07.tar.gz
gentoo-2-8ff7a15a23388f2fe9935a27e6ea2fa8c803ff07.tar.bz2
gentoo-2-8ff7a15a23388f2fe9935a27e6ea2fa8c803ff07.zip
vBump to 1.014.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-lang/dmd-bin')
-rw-r--r--dev-lang/dmd-bin/ChangeLog7
-rw-r--r--dev-lang/dmd-bin/dmd-bin-1.014.ebuild110
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-1.0143
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-lang/dmd-bin/ChangeLog b/dev-lang/dmd-bin/ChangeLog
index d54308777f27..56c39823f3e6 100644
--- a/dev-lang/dmd-bin/ChangeLog
+++ b/dev-lang/dmd-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/dmd-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.4 2007/05/20 20:37:11 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.5 2007/05/20 21:23:08 anant Exp $
+
+*dmd-bin-1.014 (21 May 2007)
+
+ 21 May 2007; Anant Narayanan <anant@gentoo.org> +dmd-bin-1.014.ebuild:
+ vBump to 1.014.
*dmd-bin-1.010 (21 May 2007)
diff --git a/dev-lang/dmd-bin/dmd-bin-1.014.ebuild b/dev-lang/dmd-bin/dmd-bin-1.014.ebuild
new file mode 100644
index 000000000000..bf36ad4da97e
--- /dev/null
+++ b/dev-lang/dmd-bin/dmd-bin-1.014.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-1.014.ebuild,v 1.1 2007/05/20 21:23:08 anant Exp $
+
+inherit eutils
+
+MY_P=${P/-bin/}
+MY_P=${MY_P/-/.}
+
+DESCRIPTION="Digital Mars D Compiler"
+HOMEPAGE="http://www.digitalmars.com/d/"
+SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
+
+LICENSE="DMD"
+RESTRICT="mirror nostrip"
+SLOT="0"
+KEYWORDS="~x86"
+
+LOC="/opt/dmd"
+S="${WORKDIR}"
+
+DEPEND="sys-apps/findutils"
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+
+src_unpack() {
+ unpack ${A}
+
+ # Remove unneccessary files
+ mv ${S}/dmd/lib/libphobos.a ${S}/dmd
+ rm -r ${S}/dmd/lib
+ mkdir ${S}/dmd/lib
+ mv ${S}/dmd/libphobos.a ${S}/dmd/lib
+
+ rm -r ${S}/dm
+ rm ${S}/dmd/bin/*.dll ${S}/dmd/bin/*.exe ${S}/dmd/bin/readme.txt
+ rm ${S}/dmd/bin/sc.ini ${S}/dmd/bin/windbg.hlp
+
+ # Cleanup line endings
+ cd ${S}/dmd
+ edos2unix `find . -name '*.c' -type f`
+ edos2unix `find . -name '*.d' -type f`
+ edos2unix `find . -name '*.ddoc' -type f`
+ edos2unix `find . -name '*.h' -type f`
+ edos2unix `find . -name '*.mak' -type f`
+ edos2unix `find . -name '*.txt' -type f`
+ edos2unix `find samples -name '*.html' -type f`
+
+ # Fix permissions
+ fperms guo=r `find . -type f`
+ fperms guo=rx `find . -type d`
+ fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
+}
+
+src_compile() {
+ cd ${S}/dmd/src/phobos
+ sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd -I${S}/dmd/src/phobos -L${S}/dmd/lib/libphobos.a:" linux.mak internal/gc/linux.mak
+ edos2unix linux.mak internal/gc/linux.mak
+ make -f linux.mak
+ cp libphobos.a ${S}/dmd/lib
+
+ # Clean up
+ make -f linux.mak clean
+ rm internal/gc/*.o
+}
+
+src_install() {
+ cd ${S}/dmd
+
+ # Broken dmd.conf
+ # http://d.puremagic.com/issues/show_bug.cgi?id=278
+ mv bin/dmd bin/dmd.bin
+ cat <<END > "bin/dmd"
+#!/bin/sh
+${LOC}/bin/dmd.bin -I${LOC}/src/phobos -L${LOC}/lib/libphobos.a \$*
+END
+ fperms guo=rx bin/dmd bin/dmd.bin
+
+ # Man pages
+ doman man/man1/dmd.1
+ doman man/man1/dumpobj.1
+ doman man/man1/obj2asm.1
+ rm -r man
+
+ # Install
+ mkdir "${D}/opt"
+ mv "${S}/dmd" "${D}/opt/dmd"
+
+ # Set PATH
+ doenvd "${FILESDIR}/25dmd"
+}
+
+pkg_postinst () {
+ ewarn "The DMD Configuration file has been disabled, "
+ ewarn "and will be re-enabled when: "
+ ewarn " "
+ ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
+ ewarn " "
+ ewarn "has been fixed. Meanwhile, please supply all your"
+ ewarn "configuration options in the /opt/dmd/bin/dmd "
+ ewarn "shell script. "
+ ewarn " "
+ ewarn "You may need to run: "
+ ewarn " "
+ ewarn "env-update && source /etc/profile "
+ ewarn " "
+ ewarn "to be able to use the compiler immediately. "
+ ewarn " "
+}
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-1.014 b/dev-lang/dmd-bin/files/digest-dmd-bin-1.014
new file mode 100644
index 000000000000..49019970a11b
--- /dev/null
+++ b/dev-lang/dmd-bin/files/digest-dmd-bin-1.014
@@ -0,0 +1,3 @@
+MD5 e4c912d5a25bd5dca2d6e7dd1a8b3ee1 dmd.1.014.zip 4809385
+RMD160 8c16cc82abee6cdd7208d18149bdb050e2461540 dmd.1.014.zip 4809385
+SHA256 810f60f4b934fa122d69d45b9301817157f4070ade1400ea05218d7e5e32b441 dmd.1.014.zip 4809385