summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2007-12-08 00:11:23 +0000
committerHarald van Dijk <truedfx@gentoo.org>2007-12-08 00:11:23 +0000
commit547b7bcb31820a0c1b4e5e0c432bea65f697b19d (patch)
tree83f459844e359ed47efc486bc0e013ef44add5d4 /dev-lang/lazarus
parentversion bump, thanks to Arfrever Frehtes Taifersar Arahesis <Arfrever.FTA@GMa... (diff)
downloadgentoo-2-547b7bcb31820a0c1b4e5e0c432bea65f697b19d.tar.gz
gentoo-2-547b7bcb31820a0c1b4e5e0c432bea65f697b19d.tar.bz2
gentoo-2-547b7bcb31820a0c1b4e5e0c432bea65f697b19d.zip
Version bump (#201576)
(Portage version: 2.1.4_rc8)
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/ChangeLog7
-rw-r--r--dev-lang/lazarus/files/digest-lazarus-0.9.243
-rw-r--r--dev-lang/lazarus/lazarus-0.9.24.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-lang/lazarus/ChangeLog b/dev-lang/lazarus/ChangeLog
index e47986afdd2c..36f0b4c1718e 100644
--- a/dev-lang/lazarus/ChangeLog
+++ b/dev-lang/lazarus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/lazarus
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.17 2007/07/01 00:11:17 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.18 2007/12/08 00:11:23 truedfx Exp $
+
+*lazarus-0.9.24 (08 Dec 2007)
+
+ 08 Dec 2007; Harald van Dijk <truedfx@gentoo.org> +lazarus-0.9.24.ebuild:
+ Version bump (#201576)
01 Jul 2007; Harald van Dijk <truedfx@gentoo.org>
lazarus-0.9.22-r1.ebuild:
diff --git a/dev-lang/lazarus/files/digest-lazarus-0.9.24 b/dev-lang/lazarus/files/digest-lazarus-0.9.24
new file mode 100644
index 000000000000..09d77f147214
--- /dev/null
+++ b/dev-lang/lazarus/files/digest-lazarus-0.9.24
@@ -0,0 +1,3 @@
+MD5 bdb0221240d776e4bc32733f2872e2b1 lazarus-0.9.24-0.tar.gz 11037130
+RMD160 3f815d228397443d347d2c32a71c52b3d617d632 lazarus-0.9.24-0.tar.gz 11037130
+SHA256 4720c8d633c8e3d18750452278d135450c7c942ff591c10cd7d9afc6bc0f724e lazarus-0.9.24-0.tar.gz 11037130
diff --git a/dev-lang/lazarus/lazarus-0.9.24.ebuild b/dev-lang/lazarus/lazarus-0.9.24.ebuild
new file mode 100644
index 000000000000..0fdc94133313
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-0.9.24.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/lazarus-0.9.24.ebuild,v 1.1 2007/12/08 00:11:23 truedfx Exp $
+
+inherit eutils
+
+# bug #183604
+RESTRICT="strip"
+
+FPCVER="2.2.0"
+
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-linking-exception"
+KEYWORDS="~amd64 ~ppc ~x86"
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi."
+HOMEPAGE="http://www.lazarus.freepascal.org/"
+IUSE=""
+SRC_URI="mirror://sourceforge/lazarus/${P}-0.tar.gz"
+
+DEPEND="~dev-lang/fpc-${FPCVER}
+ net-misc/rsync
+ >=x11-libs/gtk+-2.0"
+RDEPEND="${DEPEND}
+ !=gnome-base/librsvg-2.16.1"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use "dev-lang/fpc" source; then
+ eerror "You need to build dev-lang/fpc with the 'source' USE flag"
+ eerror "in order for lazarus to work properly."
+ die "lazarus needs fpc built with the 'source' USE to work."
+ fi
+}
+
+src_unpack() {
+ # check for broken fpc.cfg
+ # don't check in pkg_setup since it won't harm binpkgs
+ if grep -q '^[ ]*-Fu.*/lcl$' /etc/fpc.cfg
+ then
+ eerror "Your /etc/fpc.cfg automatically adds a LCL directory"
+ eerror "to the list of unit directories. This will break the"
+ eerror "build of lazarus."
+ die "don't set the LCL path in /etc/fpc.cfg"
+ fi
+
+ unpack ${A}
+ sed -e "s/@FPCVER@/${FPCVER}/" "${FILESDIR}"/${PN}-0.9.20-fpcsrc.patch \
+ > "${T}"/fpcsrc.patch || die "could not sed fpcsrc patch"
+
+ cd "${S}"
+ epatch "${T}"/fpcsrc.patch
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake -j1 || die "make failed!"
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ --exclude="debian" --exclude="COPYING*" \
+ --exclude="*.app" \
+ "${S}" "${D}"usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../lazarus/images/mainicon.xpm /usr/share/pixmaps/lazarus.xpm
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus.xpm" || die "Failed making desktop entry!"
+}