summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-12-18 10:27:58 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-12-18 10:27:58 +0000
commitf6db445cc86c23ebc03873395a60dcb33cfe05f7 (patch)
treea8b5132cb29a41bcadfec5051974127a946f887a /dev-lang
parentVersion bump (diff)
downloadgentoo-2-f6db445cc86c23ebc03873395a60dcb33cfe05f7.tar.gz
gentoo-2-f6db445cc86c23ebc03873395a60dcb33cfe05f7.tar.bz2
gentoo-2-f6db445cc86c23ebc03873395a60dcb33cfe05f7.zip
clean up
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog8
-rw-r--r--dev-lang/erlang/erlang-12.2.3-r1.ebuild159
-rw-r--r--dev-lang/erlang/erlang-12.2.4-r1.ebuild158
-rw-r--r--dev-lang/erlang/files/erlang-12.2.3-gethostbyname.patch12
-rw-r--r--dev-lang/erlang/files/erlang-12.2.3-glibc28.patch11
-rw-r--r--dev-lang/erlang/files/erlang-12.2.4-inet_drv.patch31
6 files changed, 7 insertions, 372 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index ab6d3e36ff06..cb0d324b8081 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.147 2008/12/17 22:21:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.148 2008/12/18 10:27:58 fauli Exp $
+
+ 18 Dec 2008; Christian Faulhammer <fauli@gentoo.org>
+ -files/erlang-12.2.3-gethostbyname.patch,
+ -files/erlang-12.2.3-glibc28.patch, -files/erlang-12.2.4-inet_drv.patch,
+ -erlang-12.2.3-r1.ebuild, -erlang-12.2.4-r1.ebuild:
+ clean up
17 Dec 2008; Markus Meier <maekke@gentoo.org> erlang-12.2.5.ebuild:
amd64 stable, bug #249960
diff --git a/dev-lang/erlang/erlang-12.2.3-r1.ebuild b/dev-lang/erlang/erlang-12.2.3-r1.ebuild
deleted file mode 100644
index f4d287663b2f..000000000000
--- a/dev-lang/erlang/erlang-12.2.3-r1.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.3-r1.ebuild,v 1.6 2008/08/29 10:08:15 opfer Exp $
-
-inherit autotools elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # fixes bug 226063, reported and accepted upstream for R12B-4
- epatch "${FILESDIR}"/${P}-glibc28.patch
-
- # Fix build on Gentoo/FreeBSD, upstream once accepted it but restored previous behaviour
- # because of failures on vanilla BSD
- epatch "${FILESDIR}"/${P}-gethostbyname.patch
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it! If you have fix, tell us."
- ewarn
- fi
- eautoreconf
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el || die
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of Erlang's binaries,"
- elog "please open a bug on http://bugs.gentoo.org/"
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-12.2.4-r1.ebuild b/dev-lang/erlang/erlang-12.2.4-r1.ebuild
deleted file mode 100644
index f210b6117a51..000000000000
--- a/dev-lang/erlang/erlang-12.2.4-r1.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.4-r1.ebuild,v 1.1 2008/10/03 18:52:07 opfer Exp $
-
-inherit autotools elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: If you need symlinks for binaries please tell maintainers or
-# open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp sctp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- sctp? ( net-misc/lksctp-tools )
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50${PN}-gentoo.el
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # Fix build on Gentoo/FreeBSD, upstream once accepted it but restored previous behaviour
- # because of failures on vanilla BSD
- epatch "${FILESDIR}"/${PN}-12.2.3-gethostbyname.patch
- # incorporated by upstream for 12B-5 or later, fixes runtime issues from bug 239173
- epatch "${FILESDIR}"/${P}-inet_drv.patch
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it! If you have fix, tell us."
- ewarn
- fi
- eautoreconf
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable sctp) \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable ssl dynamic-ssl-lib) \
- $(use_enable kpoll kernel-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el || die
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of Erlang's binaries,"
- elog "please open a bug on http://bugs.gentoo.org/"
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as ${MY_PV}"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/files/erlang-12.2.3-gethostbyname.patch b/dev-lang/erlang/files/erlang-12.2.3-gethostbyname.patch
deleted file mode 100644
index cdb0376b1058..000000000000
--- a/dev-lang/erlang/files/erlang-12.2.3-gethostbyname.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur otp_src_R11B-4.orig/lib/erl_interface/src/connect/ei_resolve.c otp_src_R11B-4/lib/erl_interface/src/connect/ei_resolve.c
---- otp_src_R11B-4.orig/lib/erl_interface/src/connect/ei_resolve.c 2006-11-06 14:53:29 +0100
-+++ otp_src_R11B-4/lib/erl_interface/src/connect/ei_resolve.c 2007-06-13 23:14:06 +0200
-@@ -614,7 +615,7 @@
- #ifndef HAVE_GETHOSTBYNAME_R
- return my_gethostbyname_r(name,hostp,buffer,buflen,h_errnop);
- #else
--#ifdef __GLIBC__
-+#if (defined(__GLIBC__) || (__FreeBSD_version >= 602000))
- struct hostent *result;
-
- gethostbyname_r(name, hostp, buffer, buflen, &result, h_errnop);
diff --git a/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch b/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch
deleted file mode 100644
index d13053a8bb03..000000000000
--- a/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- erts/emulator/hipe/hipe_x86_signal.c 2008-06-12 14:17:48.831373565 +0200
-+++ erts/emulator/hipe/hipe_x86_signal_ok.c 2008-06-12 14:43:05.132064804 +0200
-@@ -34,7 +34,7 @@
- #endif
- #include "hipe_signal.h"
-
--#if __GLIBC__ == 2 && (__GLIBC_MINOR__ >= 3 && __GLIBC_MINOR__ <= 7)
-+#if __GLIBC__ == 2 && __GLIBC_MINOR__ >= 3
- /* See comment below for glibc 2.2. */
- #ifndef __USE_GNU
- #define __USE_GNU /* to un-hide RTLD_NEXT */
diff --git a/dev-lang/erlang/files/erlang-12.2.4-inet_drv.patch b/dev-lang/erlang/files/erlang-12.2.4-inet_drv.patch
deleted file mode 100644
index 8baca6ebe3c0..000000000000
--- a/dev-lang/erlang/files/erlang-12.2.4-inet_drv.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- otp_src_R12B-4.orig/erts/emulator/drivers/common/inet_drv.c 2008-09-01 05:51:18.000000000 -0700
-+++ otp_src_R12B-4/erts/emulator/drivers/common/inet_drv.c 2008-09-30 10:38:06.000000000 -0700
-@@ -7239,19 +7239,18 @@
- buf, &len) == NULL)
- return ctl_error(EINVAL, rbuf, rsize);
-
-- sock_select(INETP(desc), FD_CONNECT, 1);
- code = sock_connect(desc->inet.s,
- (struct sockaddr*) &desc->inet.remote, len);
- if ((code == SOCKET_ERROR) &&
- ((sock_errno() == ERRNO_BLOCK) || /* Winsock2 */
- (sock_errno() == EINPROGRESS))) { /* Unix & OSE!! */
- desc->inet.state = TCP_STATE_CONNECTING;
-+ sock_select(INETP(desc), FD_CONNECT, 1);
- if (timeout != INET_INFINITY)
- driver_set_timer(desc->inet.port, timeout);
- enq_async(INETP(desc), tbuf, INET_REQ_CONNECT);
- }
- else if (code == 0) { /* ok we are connected */
-- sock_select(INETP(desc), FD_CONNECT, 0);
- desc->inet.state = TCP_STATE_CONNECTED;
- if (desc->inet.active)
- sock_select(INETP(desc), (FD_READ|FD_CLOSE), 1);
-@@ -7259,7 +7258,6 @@
- async_ok(INETP(desc));
- }
- else {
-- sock_select(INETP(desc), FD_CONNECT, 0);
- return ctl_error(sock_errno(), rbuf, rsize);
- }
- return ctl_reply(INET_REP_OK, tbuf, 2, rbuf, rsize);