summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-04-11 16:12:34 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-04-11 16:12:34 +0000
commitb6061b5600790bbc5856bcbb1ef18b022c856417 (patch)
tree62dfc7a31995816cd820000995937934eddd2508 /dev-libs/cyrus-imap-dev
parentAdd ~alpha/~ia64 wrt #260777 (diff)
downloadgentoo-2-b6061b5600790bbc5856bcbb1ef18b022c856417.tar.gz
gentoo-2-b6061b5600790bbc5856bcbb1ef18b022c856417.tar.bz2
gentoo-2-b6061b5600790bbc5856bcbb1ef18b022c856417.zip
Version bump
(Portage version: 2.2_rc29/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cyrus-imap-dev')
-rw-r--r--dev-libs/cyrus-imap-dev/ChangeLog8
-rw-r--r--dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.14.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-libs/cyrus-imap-dev/ChangeLog b/dev-libs/cyrus-imap-dev/ChangeLog
index 47767b275591..dabf3e330b1f 100644
--- a/dev-libs/cyrus-imap-dev/ChangeLog
+++ b/dev-libs/cyrus-imap-dev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cyrus-imap-dev
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/ChangeLog,v 1.55 2009/02/16 18:55:09 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/ChangeLog,v 1.56 2009/04/11 16:12:34 dertobi123 Exp $
+
+*cyrus-imap-dev-2.3.14 (11 Apr 2009)
+
+ 11 Apr 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +cyrus-imap-dev-2.3.14.ebuild:
+ Version bump
16 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
-cyrus-imap-dev-2.3.9.ebuild, -cyrus-imap-dev-2.3.11.ebuild:
diff --git a/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.14.ebuild b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.14.ebuild
new file mode 100644
index 000000000000..801738a8609f
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.14.ebuild,v 1.1 2009/04/11 16:12:34 dertobi123 Exp $
+
+inherit eutils autotools
+
+MY_PV="${PV/_/}"
+
+DESCRIPTION="Developer support for the Cyrus IMAP Server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="afs kerberos snmp ssl tcpd"
+
+RDEPEND="virtual/libc
+ >=sys-libs/db-3.2
+ >=dev-libs/cyrus-sasl-2.1.12
+ afs? ( >=net-fs/openafs-1.2.2 )
+ kerberos? ( >=app-crypt/mit-krb5-1.2.6 )
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Add libwrap defines as we don't have a dynamicly linked library.
+ if use tcpd ; then
+ epatch "${FILESDIR}/cyrus-imapd-libwrap.patch" || die "patch failed"
+ fi
+
+ # DB4 detection and versioned symbols.
+ #epatch "${FILESDIR}/cyrus-imapd-${PV}-db4.patch" || die "patch failed."
+
+ # Recreate configure.
+ export WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_with afs`"
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with snmp ucdsnmp`"
+ myconf="${myconf} `use_with tcpd libwrap`"
+ myconf="${myconf} `use_enable kerberos gssapi`"
+
+ econf \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --without-perl \
+ ${myconf} || die "econf failed"
+
+ emake -C "${S}/lib" all || die "compile problem"
+}
+
+src_install() {
+ dodir /usr/include/cyrus
+
+ make -C "${S}/lib" DESTDIR="${D}" install || die "make install failed"
+ dodoc COPYRIGHT README*
+}