summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-09-20 22:10:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-09-20 22:10:38 +0000
commit0c66ab35280d2b32dd506d1aaac83eaddd2fb380 (patch)
treebbc7f8203492f0eed96d9198d6a3e99284a160a3 /dev-libs/gmime
parentamd64 stable, bug 238206 (diff)
downloadgentoo-2-0c66ab35280d2b32dd506d1aaac83eaddd2fb380.tar.gz
gentoo-2-0c66ab35280d2b32dd506d1aaac83eaddd2fb380.tar.bz2
gentoo-2-0c66ab35280d2b32dd506d1aaac83eaddd2fb380.zip
bump to 2.2.23. Bug fixes and drop -j1 per bug #236016.
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/ChangeLog8
-rw-r--r--dev-libs/gmime/gmime-2.2.23.ebuild70
-rw-r--r--dev-libs/gmime/metadata.xml1
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index f9f8f600d93a..f7e35edff028 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.72 2008/08/17 21:02:40 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.73 2008/09/20 22:10:38 eva Exp $
+
+*gmime-2.2.23 (20 Sep 2008)
+
+ 20 Sep 2008; Gilles Dartiguelongue <eva@gentoo.org> metadata.xml,
+ +gmime-2.2.23.ebuild:
+ bump to 2.2.23. Bug fixes and drop -j1 per bug #236016.
17 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org> -gmime-2.1.19.ebuild,
gmime-2.2.3.ebuild, gmime-2.2.11.ebuild, gmime-2.2.17.ebuild:
diff --git a/dev-libs/gmime/gmime-2.2.23.ebuild b/dev-libs/gmime/gmime-2.2.23.ebuild
new file mode 100644
index 000000000000..a09eb4c297c0
--- /dev/null
+++ b/dev-libs/gmime/gmime-2.2.23.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.2.23.ebuild,v 1.1 2008/09/20 22:10:38 eva Exp $
+
+inherit gnome2 eutils mono libtool
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+SRC_URI="http://spruce.sourceforge.net/${PN}/sources/v${PV%.*}/${P}.tar.gz"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc mono"
+
+RDEPEND=">=dev-libs/glib-2
+ mono? ( dev-lang/mono
+ >=dev-dotnet/gtk-sharp-2.4.0 )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1.0
+ app-text/docbook-sgml-utils )"
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS PORTING README TODO doc/html/"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use doc ; then
+ #db2html should be docbook2html
+ sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
+ docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
+ || die "sed failed (1)"
+ # Fix doc targets (bug #97154)
+ sed -i -e 's!\<\(tmpl-build.stamp\): !\1 $(srcdir)/tmpl/*.sgml: !' \
+ gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
+ fi
+
+ # Use correct libdir for mono assembly
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -e 's:^prefix=:exec_prefix=:' \
+ -e 's:prefix)/lib:libdir):' \
+ mono/gmime-sharp.pc.in mono/Makefile.{am,in} || die "sed failed (2)"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable mono) $(use_enable doc gtk-doc)
+ MONO_PATH="${S}" emake || die "make failed"
+}
+
+src_install() {
+ emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR="${D}" install || die "installation failed"
+
+ if use doc ; then
+ # we don't use docinto/dodoc, because we don't want html doc gzipped
+ insinto /usr/share/doc/${PF}/tutorial
+ doins docs/tutorial/html/*
+ fi
+
+ # rename these two, so they don't conflict with app-arch/sharutils
+ # (bug #70392) Ticho, 2004-11-10
+ mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode"
+ mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode"
+}
diff --git a/dev-libs/gmime/metadata.xml b/dev-libs/gmime/metadata.xml
index 51f94e3fbe0e..8461c9734860 100644
--- a/dev-libs/gmime/metadata.xml
+++ b/dev-libs/gmime/metadata.xml
@@ -2,4 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-mail</herd>
+<herd>gnome</herd>
</pkgmetadata>