summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-18 17:50:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-18 17:50:14 +0000
commit33e655e40e0ade6be33d93e9c479e4a3d2164680 (patch)
tree19d3d5c1cd1ea0aa4c8303e7d034523d5ca002d6 /dev-libs/libelf
parentDropped old (diff)
downloadgentoo-2-33e655e40e0ade6be33d93e9c479e4a3d2164680.tar.gz
gentoo-2-33e655e40e0ade6be33d93e9c479e4a3d2164680.tar.bz2
gentoo-2-33e655e40e0ade6be33d93e9c479e4a3d2164680.zip
Apply a patch to sanitise build system that actually allows for it to pass properly. Also fix bug #347059, and make the package cross-compilable.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libelf')
-rw-r--r--dev-libs/libelf/ChangeLog10
-rw-r--r--dev-libs/libelf/files/libelf-0.8.13-build.patch38
-rw-r--r--dev-libs/libelf/libelf-0.8.12.ebuild51
-rw-r--r--dev-libs/libelf/libelf-0.8.13-r1.ebuild (renamed from dev-libs/libelf/libelf-0.8.13.ebuild)39
4 files changed, 65 insertions, 73 deletions
diff --git a/dev-libs/libelf/ChangeLog b/dev-libs/libelf/ChangeLog
index f58571c65ae7..9c6bec709bbd 100644
--- a/dev-libs/libelf/ChangeLog
+++ b/dev-libs/libelf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libelf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.29 2010/04/24 15:07:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.30 2010/11/18 17:50:14 flameeyes Exp $
+
+*libelf-0.8.13-r1 (18 Nov 2010)
+
+ 18 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org> -libelf-0.8.12.ebuild,
+ -libelf-0.8.13.ebuild, +libelf-0.8.13-r1.ebuild,
+ +files/libelf-0.8.13-build.patch:
+ Apply a patch to sanitise build system that actually allows for it to pass
+ properly. Also fix bug #347059, and make the package cross-compilable.
*libelf-0.8.13 (24 Apr 2010)
diff --git a/dev-libs/libelf/files/libelf-0.8.13-build.patch b/dev-libs/libelf/files/libelf-0.8.13-build.patch
new file mode 100644
index 000000000000..57173d6138a2
--- /dev/null
+++ b/dev-libs/libelf/files/libelf-0.8.13-build.patch
@@ -0,0 +1,38 @@
+Index: libelf-0.8.13/aclocal.m4
+===================================================================
+--- libelf-0.8.13.orig/aclocal.m4
++++ libelf-0.8.13/aclocal.m4
+@@ -235,7 +235,7 @@ AC_DEFUN(mr_ENABLE_SHARED, [
+ AC_REQUIRE([AC_PROG_CC])
+ AC_PATH_PROG(LD, ld, ld)
+ case "$host" in
+- *-linux*|*-gnu*)
++ *-linux*|*-gnu*|*-freebsd*)
+ if test "$GCC" = yes; then
+ mr_TARGET_ELF
+ if test "$mr_cv_target_elf" = yes; then
+Index: libelf-0.8.13/lib/Makefile.in
+===================================================================
+--- libelf-0.8.13.orig/lib/Makefile.in
++++ libelf-0.8.13/lib/Makefile.in
+@@ -158,7 +158,7 @@ libelf.a: $(OBJS) $(LIBOBJS)
+
+ $(SHLIB): libelf.a
+ @$(RM) $(SHLIB)
+- $(LINK_SHLIB) -o $(SHLIB) $(OBJS:.o=.os) $(LIBOBJS:.o=.os) $(DEPSHLIBS)
++ $(LINK_SHLIB) $(LDFLAGS) -o $(SHLIB) $(OBJS:.o=.os) $(LIBOBJS:.o=.os) $(DEPSHLIBS)
+ if test "$(SONAME)" = "$(SHLIB)"; then true; else \
+ $(RM) $(SONAME) && $(LN_S) $(SHLIB) $(SONAME); \
+ fi
+@@ -169,9 +169,9 @@ $(SHLIB): libelf.a
+ install: install-data \
+ install-shared-$(DO_SHLIB) install-compat-$(DO_COMPAT)
+
+-installdirs: $(top_srcdir)/mkinstalldirs
++installdirs:
+ dirs="$(installdirs)"; for dir in $$dirs; do \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(instroot)$$dir; \
++ mkdir -p $(instroot)$$dir; \
+ done
+
+ install-data: all installdirs
diff --git a/dev-libs/libelf/libelf-0.8.12.ebuild b/dev-libs/libelf/libelf-0.8.12.ebuild
deleted file mode 100644
index 0e66d0893be7..000000000000
--- a/dev-libs/libelf/libelf-0.8.12.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.12.ebuild,v 1.1 2009/11/21 09:24:32 patrick Exp $
-
-inherit multilib eutils
-
-DESCRIPTION="A ELF object file access library"
-HOMEPAGE="http://www.mr511.de/software/"
-SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug nls elibc_FreeBSD"
-
-DEPEND="!dev-libs/elfutils
- nls? ( sys-devel/gettext )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use elibc_FreeBSD; then
- # Stop libelf from stamping on the system nlist.h
- sed -i -e 's:nlist.h::g' lib/Makefile.in || die
-
- # Enable shared libs
- sed -i \
- -e 's:\*-linux\*\|\*-gnu\*:\*-linux\*\|\*-gnu\*\|\*-freebsd\*:' \
- configure || die
- fi
-}
-
-src_compile() {
- econf \
- $(use_enable nls) \
- $(use_enable debug) \
- --enable-shared \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake -j1 \
- prefix="${D}"/usr \
- libdir="${D}"usr/$(get_libdir) \
- install \
- install-compat || die "emake install failed"
- dodoc ChangeLog VERSION README
-}
diff --git a/dev-libs/libelf/libelf-0.8.13.ebuild b/dev-libs/libelf/libelf-0.8.13-r1.ebuild
index 8baf38e182de..b7e694938d18 100644
--- a/dev-libs/libelf/libelf-0.8.13.ebuild
+++ b/dev-libs/libelf/libelf-0.8.13-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.13.ebuild,v 1.1 2010/04/24 15:07:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.13-r1.ebuild,v 1.1 2010/11/18 17:50:14 flameeyes Exp $
EAPI=2
-inherit eutils multilib
+inherit eutils multilib autotools
DESCRIPTION="A ELF object file access library"
HOMEPAGE="http://www.mr511.de/software/"
@@ -15,28 +15,20 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="debug nls elibc_FreeBSD"
RDEPEND="!dev-libs/elfutils"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="nls? ( sys-devel/gettext )"
src_prepare() {
- if use elibc_FreeBSD; then
- # Stop libelf from stamping on the system nlist.h
- sed -i \
- -e 's:nlist.h::g' \
- lib/Makefile.in || die
-
- # Enable shared libs
- sed -i \
- -e 's:\*-linux\*\|\*-gnu\*:\*-linux\*\|\*-gnu\*\|\*-freebsd\*:' \
- configure || die
- fi
-
- sed -i \
- -e 's:$(LINK_SHLIB) -o:$(LINK_SHLIB) $(LDFLAGS) -o:' \
- lib/Makefile.in || die
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+
}
src_configure() {
+ # prefix might want to play with this; unfortunately the stupid
+ # macro used to detect whether we're building ELF is so screwed up
+ # that trying to fix it is just a waste of time.
+ export mr_cv_target_elf=yes
+
econf \
$(use_enable nls) \
--enable-shared \
@@ -44,10 +36,15 @@ src_configure() {
}
src_install() {
- emake -j1 \
+ emake \
prefix="${D}usr" \
libdir="${D}usr/$(get_libdir)" \
install \
install-compat || die
- dodoc ChangeLog README
+
+ dodoc ChangeLog README || die
+
+ # Stop libelf from stamping on the system nlist.h
+ use elibc_FreeBSD && rm "${D}"/usr/include/nlist.h
}
+