summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-02-23 11:26:41 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-02-23 11:26:41 +0000
commit9e78574c4ca82ac54aa76e82de48fb5bb43aee01 (patch)
treed71f88973ce96721f066e6bd03b9569a21b63c12 /dev-libs/liblognorm
parentStable for ppc64, wrt bug #535326 (diff)
downloadgentoo-2-9e78574c4ca82ac54aa76e82de48fb5bb43aee01.tar.gz
gentoo-2-9e78574c4ca82ac54aa76e82de48fb5bb43aee01.tar.bz2
gentoo-2-9e78574c4ca82ac54aa76e82de48fb5bb43aee01.zip
fix #536778 by Thomas D.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-libs/liblognorm')
-rw-r--r--dev-libs/liblognorm/ChangeLog10
-rw-r--r--dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch41
-rw-r--r--dev-libs/liblognorm/liblognorm-1.1.0.ebuild48
3 files changed, 97 insertions, 2 deletions
diff --git a/dev-libs/liblognorm/ChangeLog b/dev-libs/liblognorm/ChangeLog
index 6c1678a2cf06..1c90fe1bffdd 100644
--- a/dev-libs/liblognorm/ChangeLog
+++ b/dev-libs/liblognorm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/liblognorm
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblognorm/ChangeLog,v 1.31 2014/10/05 07:25:00 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblognorm/ChangeLog,v 1.32 2015/02/23 11:26:41 ultrabug Exp $
+
+*liblognorm-1.1.0 (23 Feb 2015)
+
+ 23 Feb 2015; Ultrabug <ultrabug@gentoo.org> +liblognorm-1.1.0.ebuild,
+ +files/liblognorm-1.1.0-fix-enable-docs.patch:
+ version bump fix #536778 by Thomas D.
05 Oct 2014; Agostino Sarubbo <ago@gentoo.org> liblognorm-1.0.1.ebuild:
Stable for x86, wrt bug #524290
diff --git a/dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch b/dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch
new file mode 100644
index 000000000000..3bffe5ec74f0
--- /dev/null
+++ b/dev-libs/liblognorm/files/liblognorm-1.1.0-fix-enable-docs.patch
@@ -0,0 +1,41 @@
+[PATCH] Turn --disable-docs into --enable-docs and make it work
+
+See upstream issue #16 for more details.
+---
+ configure.ac | 22 ++++++++++++++--------
+ 1 file changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 547908c..26a2f96 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -96,15 +96,21 @@ fi
+
+ # docs (html) build settings
+ AC_ARG_ENABLE(docs,
+- [AS_HELP_STRING([--disable-docs],[Disable building HTML docs (requires Sphinx)])],
+- [enable_docs="no"],
+- [enable_docs="yes"]
++ [AS_HELP_STRING([--enable-docs],[Enable building HTML docs (requires Sphinx) @<:@default=no@:>@])],
++ [case "${enableval}" in
++ yes) enable_docs="yes" ;;
++ no) enable_docs="no" ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-docs) ;;
++ esac],
++ [enable_docs="no"]
+ )
+-AC_CHECK_PROGS([SPHINXBUILD], [sphinx-build sphinx-build3 sphinx-build2], [no])
+-AS_IF([test "$enable_docs" = "yes" -a "x$SPHINXBUILD" = xno],
+- [AC_MSG_ERROR([sphinx-build is required to build documentation, install it or try --disable-docs])]
+-)
+-AM_CONDITIONAL([ENABLE_DOCS], [test "$enable_docs" = yes])
++if test "$enable_docs" = "yes"; then
++ AC_CHECK_PROGS([SPHINXBUILD], [sphinx-build sphinx-build3 sphinx-build2], [no])
++ if test "$SPHINXBUILD" = "no"; then
++ AC_MSG_ERROR([sphinx-build is required to build documentation, install it or try --disable-docs])
++ fi
++fi
++AM_CONDITIONAL([ENABLE_DOCS], [test "$enable_docs" = "yes"])
+
+ AC_ARG_ENABLE(testbench,
+ [AS_HELP_STRING([--enable-testbench],[testbench enabled @<:@default=no@:>@])],
diff --git a/dev-libs/liblognorm/liblognorm-1.1.0.ebuild b/dev-libs/liblognorm/liblognorm-1.1.0.ebuild
new file mode 100644
index 000000000000..1629e97de877
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-1.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblognorm/liblognorm-1.1.0.ebuild,v 1.1 2015/02/23 11:26:41 ultrabug Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF="yes"
+
+inherit autotools-utils
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-linux"
+IUSE="debug doc pcre static-libs test"
+
+RDEPEND="
+ >=dev-libs/libestr-0.1.3
+ >=dev-libs/json-c-0.11:=
+ pcre? ( >=dev-libs/libpcre-8.35 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}"/respect_CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.1.0-fix-enable-docs.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc docs)
+ $(use_enable pcre regexp)
+ $(use_enable test testbench)
+ )
+
+ autotools-utils_src_configure
+}