summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-25 14:58:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-25 14:58:16 +0000
commit2f4e160c65f33ca589e04aae87a6f82825e4c3f1 (patch)
treec6cf20132361e41d2247bff461893a7acbfcbc8a /dev-libs/librapi2/librapi2-0.15.2.ebuild
parentx86 stable per bug 348320 (diff)
downloadgentoo-2-2f4e160c65f33ca589e04aae87a6f82825e4c3f1.tar.gz
gentoo-2-2f4e160c65f33ca589e04aae87a6f82825e4c3f1.tar.bz2
gentoo-2-2f4e160c65f33ca589e04aae87a6f82825e4c3f1.zip
Initial commit.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/librapi2/librapi2-0.15.2.ebuild')
-rw-r--r--dev-libs/librapi2/librapi2-0.15.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/librapi2/librapi2-0.15.2.ebuild b/dev-libs/librapi2/librapi2-0.15.2.ebuild
new file mode 100644
index 000000000000..1d8bcf18e6f4
--- /dev/null
+++ b/dev-libs/librapi2/librapi2-0.15.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librapi2/librapi2-0.15.2.ebuild,v 1.1 2011/02/25 14:58:16 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit python
+
+DESCRIPTION="A library for SynCE"
+HOMEPAGE="http://www.synce.org/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus python static-libs"
+
+RDEPEND=">=dev-libs/libsynce-0.15.1
+ dbus? ( >=dev-libs/dbus-glib-0.88 )
+ python? ( >=dev-python/pyrex-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable dbus odccm-support) \
+ --disable-hal-support \
+ $(use_enable dbus udev-support) \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUGS ChangeLog README* TODO
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}