summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-26 11:10:21 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-26 11:10:21 +0000
commit93249b7563681b2a642ddb059ebec462c4ccad48 (patch)
tree0907363794739883aa30b8c5b5e01799b8f65e88 /dev-libs/libsodium
parentnet-libs/zeromq: Remove README from dodoc, #489442; fix die() usage (diff)
downloadgentoo-2-93249b7563681b2a642ddb059ebec462c4ccad48.tar.gz
gentoo-2-93249b7563681b2a642ddb059ebec462c4ccad48.tar.bz2
gentoo-2-93249b7563681b2a642ddb059ebec462c4ccad48.zip
dev-libs/libsodium: Version BUmp
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-libs/libsodium')
-rw-r--r--dev-libs/libsodium/ChangeLog8
-rw-r--r--dev-libs/libsodium/libsodium-0.4.5.ebuild28
-rw-r--r--dev-libs/libsodium/metadata.xml18
3 files changed, 44 insertions, 10 deletions
diff --git a/dev-libs/libsodium/ChangeLog b/dev-libs/libsodium/ChangeLog
index 74c92dc3a770..8f8a48e25229 100644
--- a/dev-libs/libsodium/ChangeLog
+++ b/dev-libs/libsodium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libsodium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/ChangeLog,v 1.2 2013/09/10 22:41:17 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/ChangeLog,v 1.3 2013/10/26 11:10:21 jlec Exp $
+
+*libsodium-0.4.5 (26 Oct 2013)
+
+ 26 Oct 2013; Justin Lecher <jlec@gentoo.org> +libsodium-0.4.5.ebuild,
+ metadata.xml:
+ Version BUmp
10 Sep 2013; Julian Ospald <hasufell@gentoo.org> libsodium-0.4.3.ebuild,
metadata.xml:
diff --git a/dev-libs/libsodium/libsodium-0.4.5.ebuild b/dev-libs/libsodium/libsodium-0.4.5.ebuild
new file mode 100644
index 000000000000..120b16d09075
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-0.4.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/libsodium-0.4.5.ebuild,v 1.1 2013/10/26 11:10:21 jlec Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+asm static-libs +urandom"
+
+src_configure() {
+ econf \
+ $(use_enable asm) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/libsodium/metadata.xml b/dev-libs/libsodium/metadata.xml
index fe6c42ac5bf0..420556d497eb 100644
--- a/dev-libs/libsodium/metadata.xml
+++ b/dev-libs/libsodium/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>mrueg@gentoo.org</email>
- <name>Manuel Rüger</name>
- </maintainer>
- <longdescription>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <longdescription>
NaCl (pronounced "salt") is a new easy-to-use high-speed software
library for network communication, encryption, decryption,
signatures, etc. NaCl's goal is to provide all of the core
@@ -13,8 +13,8 @@
Sodium is a portable, cross-compilable, installable,
packageable fork of NaCl, with a compatible API.
</longdescription>
- <use>
- <flag name="asm">Enables assembly implementations</flag>
- <flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
- </use>
+ <use>
+ <flag name="asm">Enables assembly implementations</flag>
+ <flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
+ </use>
</pkgmetadata>