summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-09-23 00:57:45 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-09-23 00:57:45 +0000
commit5353962075f4ee949348352da1891cc7b91a550b (patch)
treef48cd2f30f2c16bcc2002a446264f02e5276012b /dev-libs/pth
parentRemove improper usage of need-autoconf. (diff)
downloadgentoo-2-5353962075f4ee949348352da1891cc7b91a550b.tar.gz
gentoo-2-5353962075f4ee949348352da1891cc7b91a550b.tar.bz2
gentoo-2-5353962075f4ee949348352da1891cc7b91a550b.zip
patch to fix hanging checking for sigstack.(bug #131234 and bug #139000).
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-libs/pth')
-rw-r--r--dev-libs/pth/ChangeLog8
-rw-r--r--dev-libs/pth/files/pth-1.4.0-sigstack.patch22
-rw-r--r--dev-libs/pth/files/pth-2.0.6-sigstack.patch22
-rw-r--r--dev-libs/pth/pth-1.4.0.ebuild5
-rw-r--r--dev-libs/pth/pth-2.0.6.ebuild3
5 files changed, 56 insertions, 4 deletions
diff --git a/dev-libs/pth/ChangeLog b/dev-libs/pth/ChangeLog
index 86be8166d485..1e039784b849 100644
--- a/dev-libs/pth/ChangeLog
+++ b/dev-libs/pth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/pth
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.40 2006/09/16 20:12:52 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/ChangeLog,v 1.41 2006/09/23 00:57:44 dragonheart Exp $
+
+ 23 Sep 2006; Daniel Black <dragonheart@gentoo.org>
+ +files/pth-1.4.0-sigstack.patch, +files/pth-2.0.6-sigstack.patch,
+ pth-1.4.0.ebuild, pth-2.0.6.ebuild:
+ patch to fix hanging checking for sigstack.(bug #131234 and bug #139000).
+ Thanks to reports by nmonkee and Miro Bogner. Patches thanks to Alon Bar-Lev
16 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org> pth-2.0.3.ebuild:
ppc stable
diff --git a/dev-libs/pth/files/pth-1.4.0-sigstack.patch b/dev-libs/pth/files/pth-1.4.0-sigstack.patch
new file mode 100644
index 000000000000..0e647c741702
--- /dev/null
+++ b/dev-libs/pth/files/pth-1.4.0-sigstack.patch
@@ -0,0 +1,22 @@
+diff -urNp pth-1.4.0.old/aclocal.m4 pth-1.4.0/aclocal.m4
+--- pth-1.4.0.old/aclocal.m4 2001-03-24 16:49:40.000000000 +0200
++++ pth-1.4.0/aclocal.m4 2006-09-20 19:45:40.000000000 +0300
+@@ -1535,6 +1535,7 @@ int main(int argc, char *argv[])
+ int sksize;
+ char result[1024];
+ int i;
++exit (1);
+ sksize = 32768;
+ skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
+ if (skbuf == NULL)
+diff -urNp pth-1.4.0.old/configure pth-1.4.0/configure
+--- pth-1.4.0.old/configure 2001-03-24 16:50:37.000000000 +0200
++++ pth-1.4.0/configure 2006-09-20 19:45:21.000000000 +0300
+@@ -4054,6 +4054,7 @@ int main(int argc, char *argv[])
+ int sksize;
+ char result[1024];
+ int i;
++exit (1);
+ sksize = 32768;
+ skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
+ if (skbuf == NULL)
diff --git a/dev-libs/pth/files/pth-2.0.6-sigstack.patch b/dev-libs/pth/files/pth-2.0.6-sigstack.patch
new file mode 100644
index 000000000000..3914dea7ac6c
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.6-sigstack.patch
@@ -0,0 +1,22 @@
+diff -urNp pth-2.0.6.old/aclocal.m4 pth-2.0.6/aclocal.m4
+--- pth-2.0.6.old/aclocal.m4 2004-12-31 21:33:19.000000000 +0200
++++ pth-2.0.6/aclocal.m4 2006-09-20 14:46:59.000000000 +0300
+@@ -1522,6 +1522,7 @@ int main(int argc, char *argv[])
+ int sksize;
+ char result[1024];
+ int i;
++exit (1);
+ sksize = 32768;
+ skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
+ if (skbuf == NULL)
+diff -urNp pth-2.0.6.old/configure pth-2.0.6/configure
+--- pth-2.0.6.old/configure 2005-11-22 09:49:21.000000000 +0200
++++ pth-2.0.6/configure 2006-09-20 14:55:23.000000000 +0300
+@@ -24735,6 +24735,7 @@ int main(int argc, char *argv[])
+ int sksize;
+ char result[1024];
+ int i;
++exit (1);
+ sksize = 32768;
+ skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
+ if (skbuf == NULL)
diff --git a/dev-libs/pth/pth-1.4.0.ebuild b/dev-libs/pth/pth-1.4.0.ebuild
index d49e7b1a8bf8..3f6f92497164 100644
--- a/dev-libs/pth/pth-1.4.0.ebuild
+++ b/dev-libs/pth/pth-1.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-1.4.0.ebuild,v 1.26 2006/07/23 02:35:52 psi29a Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-1.4.0.ebuild,v 1.27 2006/09/23 00:57:44 dragonheart Exp $
-inherit libtool
+inherit libtool eutils
DESCRIPTION="GNU Portable Threads"
HOMEPAGE="http://www.gnu.org/software/pth/"
@@ -18,6 +18,7 @@ DEPEND=""
src_unpack() {
unpack ${A}
use ppc-macos && darwintoolize
+ epatch "${FILESDIR}/${P}-sigstack.patch"
#fix warnings
sed -i "s:pow10:math_pow10:g" "${S}"/pth_string.c
sed -i "s:round:math_round:g" "${S}"/pth_string.c
diff --git a/dev-libs/pth/pth-2.0.6.ebuild b/dev-libs/pth/pth-2.0.6.ebuild
index 1e385669d7fe..cda9c41fe7cd 100644
--- a/dev-libs/pth/pth-2.0.6.ebuild
+++ b/dev-libs/pth/pth-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.6.ebuild,v 1.4 2006/05/17 12:14:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pth/pth-2.0.6.ebuild,v 1.5 2006/09/23 00:57:44 dragonheart Exp $
inherit eutils fixheadtails libtool
@@ -20,6 +20,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-2.0.5-parallelfix.patch
epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-sigstack.patch"
ht_fix_file aclocal.m4 configure