summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-07 04:48:11 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-07 04:48:11 +0000
commit903f936549a8a5533516eba610a72311c7ae3c6a (patch)
tree9d95eacdde0d53217380e161024e4579188b2edb /dev-libs/yajl/yajl-2.0.2.ebuild
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-903f936549a8a5533516eba610a72311c7ae3c6a.tar.gz
gentoo-2-903f936549a8a5533516eba610a72311c7ae3c6a.tar.bz2
gentoo-2-903f936549a8a5533516eba610a72311c7ae3c6a.zip
Version bump as reported by Johan Bergström in bug 373929. Added new slot since this version is not fully backward compatible.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yajl/yajl-2.0.2.ebuild')
-rw-r--r--dev-libs/yajl/yajl-2.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-2.0.2.ebuild b/dev-libs/yajl/yajl-2.0.2.ebuild
new file mode 100644
index 000000000000..2ffc6eb02567
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-2.0.2.ebuild,v 1.1 2011/07/07 04:48:11 graaff Exp $
+
+EAPI=3
+
+inherit cmake-utils
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE=""
+
+src_prepare() {
+ cd "${WORKDIR}"/lloyd-${PN}-*
+ S=$(pwd)
+
+ epatch "${FILESDIR}"/${PN}-fix_static_linking.patch
+}
+
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ emake test
+ popd > /dev/null
+}