summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-03-20 16:45:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-03-20 16:45:40 +0000
commit580daed09b88b6a4fc68bc6008fc292849c8bb36 (patch)
tree544bdf78497abbae4add2e3d34852d0c326c4ada /dev-libs
parentcall python_pkg_setup due to EAPI bump (diff)
downloadgentoo-2-580daed09b88b6a4fc68bc6008fc292849c8bb36.tar.gz
gentoo-2-580daed09b88b6a4fc68bc6008fc292849c8bb36.tar.bz2
gentoo-2-580daed09b88b6a4fc68bc6008fc292849c8bb36.zip
Bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/yaz/ChangeLog10
-rw-r--r--dev-libs/yaz/yaz-4.2.51.ebuild56
2 files changed, 63 insertions, 3 deletions
diff --git a/dev-libs/yaz/ChangeLog b/dev-libs/yaz/ChangeLog
index 56f69e6b09ff..e59af61f3f7e 100644
--- a/dev-libs/yaz/ChangeLog
+++ b/dev-libs/yaz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/yaz
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.71 2012/05/04 18:35:44 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.72 2013/03/20 16:45:40 robbat2 Exp $
+
+*yaz-4.2.51 (20 Mar 2013)
+
+ 20 Mar 2013; Robin H. Johnson <robbat2@gentoo.org> +yaz-4.2.51.ebuild:
+ Bump.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> yaz-3.0.26.ebuild,
yaz-3.0.36.ebuild, yaz-3.0.47.ebuild, yaz-3.0.50.ebuild, yaz-3.0.53.ebuild,
@@ -249,4 +254,3 @@
05 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> yaz-2.0.8.ebuild:
initial commit. required as a dep for bug #36693.
-
diff --git a/dev-libs/yaz/yaz-4.2.51.ebuild b/dev-libs/yaz/yaz-4.2.51.ebuild
new file mode 100644
index 000000000000..ba08cb47a3eb
--- /dev/null
+++ b/dev-libs/yaz/yaz-4.2.51.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-4.2.51.ebuild,v 1.1 2013/03/20 16:45:40 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/tcl
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.2.30-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README
+}