summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-12-14 14:13:10 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-12-14 14:13:10 +0000
commitd72fe70b29f2f6135cf9de5414d0286a33104ffe (patch)
tree0090680e5f75813c33bcdeb6e299d17607ab9f13 /dev-lua
parentVersion bump. EAPI=5. Add ruby20. Ebuild by Peter Wilmott in the ruby overlay. (diff)
downloadgentoo-2-d72fe70b29f2f6135cf9de5414d0286a33104ffe.tar.gz
gentoo-2-d72fe70b29f2f6135cf9de5414d0286a33104ffe.tar.bz2
gentoo-2-d72fe70b29f2f6135cf9de5414d0286a33104ffe.zip
version bump, update live-ebuild
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luvit/ChangeLog8
-rw-r--r--dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch54
-rw-r--r--dev-lua/luvit/luvit-0.7.0.ebuild94
-rw-r--r--dev-lua/luvit/luvit-9999.ebuild6
4 files changed, 159 insertions, 3 deletions
diff --git a/dev-lua/luvit/ChangeLog b/dev-lua/luvit/ChangeLog
index 49860d195746..1a7a6417ee12 100644
--- a/dev-lua/luvit/ChangeLog
+++ b/dev-lua/luvit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/luvit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/ChangeLog,v 1.4 2013/06/30 20:56:18 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/ChangeLog,v 1.5 2013/12/14 14:13:10 hasufell Exp $
+
+*luvit-0.7.0 (14 Dec 2013)
+
+ 14 Dec 2013; Julian Ospald <hasufell@gentoo.org> +luvit-0.7.0.ebuild,
+ +files/luvit-0.7.0-unbundle-http-parser.patch, luvit-9999.ebuild:
+ version bump, update live-ebuild
30 Jun 2013; Julian Ospald <hasufell@gentoo.org> luvit-9999.ebuild:
update live-ebuild
diff --git a/dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch b/dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch
new file mode 100644
index 000000000000..d9ae8568c140
--- /dev/null
+++ b/dev-lua/luvit/files/luvit-0.7.0-unbundle-http-parser.patch
@@ -0,0 +1,54 @@
+commit b34b7b0474878d1951637b762c68694c16c1c574
+Author: hasufell <hasufell@gentoo.org>
+Date: Sun Jun 30 22:37:10 2013 +0200
+
+ unbundle http-parser
+
+diff --git a/Makefile b/Makefile
+index a0e9277..99535ca 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,6 +40,7 @@ USE_SYSTEM_SSL?=0
+ USE_SYSTEM_LUAJIT?=0
+ USE_SYSTEM_ZLIB?=0
+ USE_SYSTEM_YAJL?=0
++USE_SYSTEM_HTTPPARSER?=0
+
+ DEBUG ?= 1
+ ifeq (${DEBUG},1)
+@@ -95,6 +96,10 @@ endif
+ LIBS += ${UVDIR}/libuv.a
+ LIBS += ${CARESDIR}/libcares.a
+
++ifeq (${USE_SYSTEM_HTTPPARSER},1)
++LIBS += -lhttp_parser
++endif
++
+ ifeq (${USE_SYSTEM_LUAJIT},1)
+ CPPFLAGS+=$(shell pkg-config --cflags luajit)
+ LIBS+=$(shell pkg-config --libs luajit)
+@@ -174,8 +179,11 @@ LUVLIBS=${BUILDDIR}/utils.o \
+ ${BUILDDIR}/lhttp_parser.o
+
+ DEPS= ${UVDIR}/libuv.a \
+- ${CARESDIR}/libcares.a \
+- ${HTTPDIR}/http_parser.o
++ ${CARESDIR}/libcares.a
++
++ifeq (${USE_SYSTEM_HTTPPARSER},0)
++DEPS += ${HTTPDIR}/http_parser.o
++endif
+
+ ifeq (${USE_SYSTEM_LUAJIT},0)
+ DEPS+=${LUADIR}/src/libluajit.a
+@@ -290,8 +298,10 @@ install: all
+ install ${BUILDDIR}/luvit ${BINDIR}/luvit
+ mkdir -p ${LIBDIR}
+ cp lib/luvit/*.lua ${LIBDIR}
++ifeq (${USE_SYSTEM_HTTPPARSER},0)
+ mkdir -p ${INCDIR}/http_parser
+ cp ${HTTPDIR}/http_parser.h ${INCDIR}/http_parser/
++endif
+ mkdir -p ${INCDIR}/uv
+ cp -r ${UVDIR}/include/* ${INCDIR}/uv/
+ cp src/*.h ${INCDIR}/
diff --git a/dev-lua/luvit/luvit-0.7.0.ebuild b/dev-lua/luvit/luvit-0.7.0.ebuild
new file mode 100644
index 000000000000..86cab036e806
--- /dev/null
+++ b/dev-lua/luvit/luvit-0.7.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/luvit-0.7.0.ebuild,v 1.1 2013/12/14 14:13:10 hasufell Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib
+
+# TODO: FHS https://github.com/luvit/luvit/issues/379
+
+DESCRIPTION="Takes node.js' architecture and dependencies and fits it in the Lua language"
+HOMEPAGE="http://luvit.io/"
+SRC_URI="http://luvit.io/dist/latest/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="bundled-libs examples"
+# luvit Apache-2.0
+# luajit MIT
+# yajl BSD
+LICENSE="Apache-2.0 bundled-libs? ( BSD MIT )"
+
+# fails in portage environment
+# succeeds if run manually
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/openssl:0
+ sys-libs/zlib
+ !bundled-libs? (
+ dev-lang/luajit:2[lua52compat]
+ >=dev-libs/yajl-2.0.2
+ net-libs/http-parser
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -r deps/{openssl,zlib} || die
+ epatch "${FILESDIR}"/${P}-unbundle-http-parser.patch
+ if use bundled-libs ; then
+ sed -i \
+ -e "s/-Werror//" \
+ -e "s/-O3//" \
+ deps/http-parser/Makefile || die "fixing flags failed!"
+ else
+ rm -r deps/{luajit,yajl,http-parser} || die
+ # TODO: no version detection for http-parser yet
+ MY_YAJL_VERSION=$($(tc-getPKG_CONFIG) --modversion yajl)
+ MY_LUAJIT_VERSION=$($(tc-getPKG_CONFIG) --modversion luajit)
+ sed -i \
+ -e "s:^YAJL_VERSION=.*:YAJL_VERSION=${MY_YAJL_VERSION}:" \
+ -e "s:^LUAJIT_VERSION=.*:LUAJIT_VERSION=${MY_LUAJIT_VERSION}:" \
+ Makefile || die "setting yajl version failed"
+ fi
+
+}
+
+src_configure() {
+ # skip retarded gyp build system
+ :
+}
+
+src_compile() {
+ tc-export CC AR
+
+ emake -C deps/cares
+
+ myemakeargs=(
+ DEBUG=0
+ WERROR=0
+ USE_SYSTEM_SSL=1
+ # bundled luajit is compiled with special flags
+ USE_SYSTEM_LUAJIT=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_YAJL=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_HTTPPARSER=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_ZLIB=1
+ PREFIX=/usr
+ LIBDIR="${D%/}"/usr/$(get_libdir)/${PN}
+ DESTDIR="${D}"
+ )
+
+ emake "${myemakeargs[@]}" all
+}
+
+src_install() {
+ emake "${myemakeargs[@]}" install
+ dodoc TODO ChangeLog README.markdown errors.markdown
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-lua/luvit/luvit-9999.ebuild b/dev-lua/luvit/luvit-9999.ebuild
index d202e50d3430..69334ecef565 100644
--- a/dev-lua/luvit/luvit-9999.ebuild
+++ b/dev-lua/luvit/luvit-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/luvit-9999.ebuild,v 1.3 2013/06/30 20:56:18 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/luvit-9999.ebuild,v 1.4 2013/12/14 14:13:10 hasufell Exp $
EAPI=5
@@ -18,7 +18,7 @@ IUSE="bundled-libs examples"
# luvit Apache-2.0
# luajit MIT
# yajl BSD
-LICENSE="Apache-2.0 !bundled-libs? ( BSD MIT )"
+LICENSE="Apache-2.0 bundled-libs? ( BSD MIT )"
# fails in portage environment
# succeeds if run manually
@@ -72,6 +72,8 @@ src_configure() {
src_compile() {
tc-export CC AR
+ emake -C deps/cares
+
myemakeargs=(
DEBUG=0
WERROR=0