summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-04-12 18:19:23 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-04-12 18:19:23 +0000
commit169874ccf4fde076d5d6d65463fc96c1afe08524 (patch)
tree09ea4ba6867f64d04e098723a1c8e63f56864d48 /dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild
parentAdd USE=pwquality to control libpwquality dep #492624 by Nikoli. (diff)
downloadgentoo-2-169874ccf4fde076d5d6d65463fc96c1afe08524.tar.gz
gentoo-2-169874ccf4fde076d5d6d65463fc96c1afe08524.tar.bz2
gentoo-2-169874ccf4fde076d5d6d65463fc96c1afe08524.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0B08240A96F66571)
Diffstat (limited to 'dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild')
-rw-r--r--dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild
new file mode 100644
index 000000000000..04573d0c3e6a
--- /dev/null
+++ b/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-wxWidgets/Alien-wxWidgets-0.670.0.ebuild,v 1.1 2015/04/12 18:19:23 dilfridge Exp $
+
+EAPI=5
+
+WX_GTK_VER=3.0
+MODULE_AUTHOR=MDOOTSON
+MODULE_VERSION=0.67
+inherit wxwidgets perl-module
+
+DESCRIPTION="Building, finding and using wxWidgets binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="gstreamer test"
+
+RDEPEND="
+ >=x11-libs/wxGTK-3:3.0[X,tiff,gstreamer=]
+ >=virtual/perl-Module-Pluggable-2.600.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-CBuilder-0.24
+ >=virtual/perl-File-Spec-1.500.0
+ >=virtual/perl-Module-Build-0.280.0
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
+
+src_configure() {
+ myconf=( --wxWidgets-build=0 )
+ perl-module_src_configure
+}