summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-29 07:02:47 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-29 07:02:47 +0000
commit516c4648356a4f33fa3108ac15303a4f6b06bdf6 (patch)
tree182661cb270be8165c11ec5063c9091f7be4d39f /dev-python/biplist
parentVersion bump, drop old. (diff)
downloadgentoo-2-516c4648356a4f33fa3108ac15303a4f6b06bdf6.tar.gz
gentoo-2-516c4648356a4f33fa3108ac15303a4f6b06bdf6.tar.bz2
gentoo-2-516c4648356a4f33fa3108ac15303a4f6b06bdf6.zip
revbump, migrate -> distutils-r1, remove old ebuilds
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/biplist')
-rw-r--r--dev-python/biplist/ChangeLog10
-rw-r--r--dev-python/biplist/biplist-0.4.ebuild25
-rw-r--r--dev-python/biplist/biplist-0.5-r1.ebuild28
-rw-r--r--dev-python/biplist/biplist-0.5.ebuild26
4 files changed, 36 insertions, 53 deletions
diff --git a/dev-python/biplist/ChangeLog b/dev-python/biplist/ChangeLog
index 6bb452cd750d..3cca6122fced 100644
--- a/dev-python/biplist/ChangeLog
+++ b/dev-python/biplist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/biplist
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/ChangeLog,v 1.3 2012/11/13 10:53:25 idella4 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/ChangeLog,v 1.4 2013/05/29 07:02:47 idella4 Exp $
+
+*biplist-0.5-r1 (29 May 2013)
+
+ 29 May 2013; Ian Delaney <idella4@gentoo.org> +biplist-0.5-r1.ebuild,
+ -biplist-0.4.ebuild:
+ revbump, migrate -> distutils-r1, remove old ebuilds
14 Nov 2012; Ian Delaney <idella4@gentoo.org> metadata.xml:
Updating maintainer, metadata.xml
diff --git a/dev-python/biplist/biplist-0.4.ebuild b/dev-python/biplist/biplist-0.4.ebuild
deleted file mode 100644
index ba72f1d6f8e2..000000000000
--- a/dev-python/biplist/biplist-0.4.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/biplist-0.4.ebuild,v 1.1 2012/04/25 19:43:51 tampakrap Exp $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-DISTUTILS_SRC_TEST=nosetests
-inherit distutils
-
-DESCRIPTION="A binary plist parser/generator for Python"
-HOMEPAGE="http://pypi.python.org/pypi/biplist/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/coverage
- dev-python/setuptools
- test? ( dev-python/nose )"
diff --git a/dev-python/biplist/biplist-0.5-r1.ebuild b/dev-python/biplist/biplist-0.5-r1.ebuild
new file mode 100644
index 000000000000..13492725f5c9
--- /dev/null
+++ b/dev-python/biplist/biplist-0.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/biplist-0.5-r1.ebuild,v 1.1 2013/05/29 07:02:47 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_6,2_7,3_2,3_3} )
+#DISTUTILS_SRC_TEST=nosetests
+inherit distutils-r1
+
+DESCRIPTION="A binary plist parser/generator for Python"
+HOMEPAGE="http://pypi.python.org/pypi/biplist/ https://github.com/wooster/biplist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://github.com/wooster/biplist/issues/5
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/biplist/biplist-0.5.ebuild b/dev-python/biplist/biplist-0.5.ebuild
deleted file mode 100644
index b32ef310bb94..000000000000
--- a/dev-python/biplist/biplist-0.5.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/biplist-0.5.ebuild,v 1.1 2012/06/28 06:11:53 patrick Exp $
-
-EAPI=4
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-DISTUTILS_SRC_TEST=nosetests
-inherit distutils
-
-DESCRIPTION="A binary plist parser/generator for Python"
-HOMEPAGE="http://pypi.python.org/pypi/biplist/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/coverage
- dev-python/setuptools
- test? ( dev-python/nose
- dev-python/six )"