summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-08 15:56:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-08 15:56:49 +0000
commitd53321b03c86e433d2c959a9db56902f86974ba6 (patch)
treef2362ddeead2b2db422919fcbdeb8f797ea1371e /dev-python/celementtree/celementtree-1.0.5-r1.ebuild
parentMarking fastjar-0.98-r1 ppc64 for bug 325557 (diff)
downloadgentoo-2-d53321b03c86e433d2c959a9db56902f86974ba6.tar.gz
gentoo-2-d53321b03c86e433d2c959a9db56902f86974ba6.tar.bz2
gentoo-2-d53321b03c86e433d2c959a9db56902f86974ba6.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/celementtree/celementtree-1.0.5-r1.ebuild')
-rw-r--r--dev-python/celementtree/celementtree-1.0.5-r1.ebuild42
1 files changed, 25 insertions, 17 deletions
diff --git a/dev-python/celementtree/celementtree-1.0.5-r1.ebuild b/dev-python/celementtree/celementtree-1.0.5-r1.ebuild
index 8430c95be9ca..e8781eca0b01 100644
--- a/dev-python/celementtree/celementtree-1.0.5-r1.ebuild
+++ b/dev-python/celementtree/celementtree-1.0.5-r1.ebuild
@@ -1,42 +1,50 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/celementtree/celementtree-1.0.5-r1.ebuild,v 1.10 2009/10/10 12:29:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/celementtree/celementtree-1.0.5-r1.ebuild,v 1.11 2010/07/08 15:56:49 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils
MY_P="cElementTree-${PV}-20051216"
+
DESCRIPTION="The cElementTree module is a C implementation of the ElementTree API"
-HOMEPAGE="http://effbot.org/zone/celementtree.htm"
+HOMEPAGE="http://effbot.org/zone/celementtree.htm http://pypi.python.org/pypi/cElementTree"
SRC_URI="http://effbot.org/downloads/${MY_P}.tar.gz"
LICENSE="ElementTree"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
-
IUSE="doc"
-DEPEND="dev-python/setuptools"
-RDEPEND=">=dev-lang/python-2.1.3-r1
- >=dev-python/elementtree-1.2
+
+RDEPEND=">=dev-python/elementtree-1.2
>=dev-libs/expat-1.95.8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ distutils_src_prepare
epatch "${FILESDIR}/${P}-use_system_expat.patch"
epatch "${FILESDIR}/${P}-setuptools.patch"
}
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" selftest.py
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
+
if use doc; then
insinto /usr/share/doc/${PF}/samples
- doins samples/*
- doins selftest.py
+ doins samples/* selftest.py || die "doins failed"
fi
}
-
-src_test() {
- PYTHONPATH="$(ls -d build/lib.*)" "${python}" selftest.py \
- || die "tests failed"
-}