summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-01 06:22:20 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-01 06:22:20 +0000
commit27ed2dd45ef8cbc9c3ba9a3e8b05002f9128728a (patch)
tree8aeb2c0d4bfa46c91e44d20eaedb874cd26c5705 /dev-python/passlib
parentAdd missing gdk-pixbuf dependency, reported by abc def. Backport auto-rotate (diff)
downloadgentoo-2-27ed2dd45ef8cbc9c3ba9a3e8b05002f9128728a.tar.gz
gentoo-2-27ed2dd45ef8cbc9c3ba9a3e8b05002f9128728a.tar.bz2
gentoo-2-27ed2dd45ef8cbc9c3ba9a3e8b05002f9128728a.zip
refactor into distutils-r1 and eapi5
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/ChangeLog8
-rw-r--r--dev-python/passlib/passlib-1.6.1.ebuild27
2 files changed, 20 insertions, 15 deletions
diff --git a/dev-python/passlib/ChangeLog b/dev-python/passlib/ChangeLog
index 2e0e6c92aebd..08ce27bbde91 100644
--- a/dev-python/passlib/ChangeLog
+++ b/dev-python/passlib/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for dev-python/passlib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/passlib/ChangeLog,v 1.1 2012/11/28 21:48:39 prometheanfire Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/passlib/ChangeLog,v 1.2 2013/01/01 06:22:20 prometheanfire Exp $
+
+ 01 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> passlib-1.6.1.ebuild:
+ refactor into distutils-r1 and eapi5
*passlib-1.6.1 (28 Nov 2012)
28 Nov 2012; Matthew Thode <prometheanfire@gentoo.org> +passlib-1.6.1.ebuild,
+metadata.xml:
adding as it is needed for keystone
-
diff --git a/dev-python/passlib/passlib-1.6.1.ebuild b/dev-python/passlib/passlib-1.6.1.ebuild
index cbfe44b8557c..9e930533adab 100644
--- a/dev-python/passlib/passlib-1.6.1.ebuild
+++ b/dev-python/passlib/passlib-1.6.1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/passlib/passlib-1.6.1.ebuild,v 1.1 2012/11/28 21:48:39 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/passlib/passlib-1.6.1.ebuild,v 1.2 2013/01/01 06:22:20 prometheanfire Exp $
-EAPI=4
+EAPI=5
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="comprehensive password hashing framework supporting over 20
schemes"
@@ -14,17 +15,19 @@ LICENSE="BSD-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="test doc"
-DEPEND="dev-python/setuptools
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose )"
RDEPEND=""
-src_install() {
- distutils_src_install
- if use doc; then
- dodoc "${S}"/docs/*
- fi
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
}
-src_test() {
- PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
+python_install() {
+ distutils-r1_python_install
+ if use doc; then
+ dodoc "${S}"/docs/*.rst
+ dodoc "${S}"/docs/requirements.txt
+ dodoc "${S}"/docs/lib/*.rst
+ fi
}