summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 20:16:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 20:16:52 +0000
commit724039c7b6cdd828372ec12ea566a3bf520b61c0 (patch)
tree5dd59f7f198f8ec405d725440ac18167a23f37b5 /dev-python/pyenchant
parentVersion bump by Justin Lecher (bug #348637). (diff)
downloadgentoo-2-724039c7b6cdd828372ec12ea566a3bf520b61c0.tar.gz
gentoo-2-724039c7b6cdd828372ec12ea566a3bf520b61c0.tar.bz2
gentoo-2-724039c7b6cdd828372ec12ea566a3bf520b61c0.zip
Version bump.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyenchant')
-rw-r--r--dev-python/pyenchant/ChangeLog8
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.4.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pyenchant/ChangeLog b/dev-python/pyenchant/ChangeLog
index 4c11476be4f8..55271669dc9b 100644
--- a/dev-python/pyenchant/ChangeLog
+++ b/dev-python/pyenchant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyenchant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.33 2010/10/31 17:48:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.34 2010/12/13 20:16:52 arfrever Exp $
+
+*pyenchant-1.6.4 (13 Dec 2010)
+
+ 13 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pyenchant-1.5.3.ebuild, -pyenchant-1.6.1.ebuild, +pyenchant-1.6.4.ebuild:
+ Version bump.
31 Oct 2010; Raúl Porcel <armin76@gentoo.org> pyenchant-1.6.3.ebuild:
sparc stable wrt #341623
diff --git a/dev-python/pyenchant/pyenchant-1.6.4.ebuild b/dev-python/pyenchant/pyenchant-1.6.4.ebuild
new file mode 100644
index 000000000000..b8fc3d597e14
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/pyenchant-1.6.4.ebuild,v 1.1 2010/12/13 20:16:52 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net http://pypi.python.org/pypi/pyenchant"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/enchant-${PV%.*}
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="README.txt TODO.txt"
+PYTHON_MODNAME="enchant"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Fix compatibility with Python 3.
+ sed -e "s/for i in xrange/for i in range/" -i enchant/__init__.py || die "sed failed"
+
+ # TestInstallEnv tests are broken with Python 3 (enchant.tokenize is wrongly imported as tokenize).
+ sed -e "s/test_basic/_&/;s/test_UnicodeInstallPath/_&/" -i enchant/tests.py || die "sed failed"
+}
+
+src_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ distutils_src_test
+ fi
+}