summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-27 03:19:12 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-27 03:19:12 +0000
commitea5cbce969ca22f0f8858a429e58ea6719ec86eb (patch)
tree0d209cc52b7ebf2bfea07656041c3eed2b613bfd /dev-python/pygame
parentVersion bump. (diff)
downloadgentoo-2-ea5cbce969ca22f0f8858a429e58ea6719ec86eb.tar.gz
gentoo-2-ea5cbce969ca22f0f8858a429e58ea6719ec86eb.tar.bz2
gentoo-2-ea5cbce969ca22f0f8858a429e58ea6719ec86eb.zip
update install phase, fix based on patch by C. Mayo wrt to bug #497720 by C. Myao, patch rm old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog9
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild8
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre3082.ebuild73
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre3203.ebuild77
4 files changed, 11 insertions, 156 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 23379663733e..2daa9e92157b 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygame
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.100 2013/09/05 18:46:31 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.101 2014/03/27 03:19:12 idella4 Exp $
+
+ 27 Mar 2014; Ian Delaney <idella4@gentoo.org> -pygame-1.9.2_pre3082.ebuild,
+ -pygame-1.9.2_pre3203.ebuild, pygame-1.9.2_pre20120101-r2.ebuild:
+ update install phase, fix based on patch by C. Mayo wrt to bug #497720 by C.
+ Myao, patch rm old
05 Sep 2013; Michał Górny <mgorny@gentoo.org>
pygame-1.9.2_pre20120101-r2.ebuild:
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
index c72326916ac5..df8d1eaf2b8c 100644
--- a/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
+++ b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild,v 1.9 2013/09/05 18:46:31 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild,v 1.10 2014/03/27 03:19:12 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -65,8 +65,8 @@ python_test() {
python_install() {
distutils-r1_python_install
- rm -fr "${D}$(python_get_sitedir)/pygame/examples"
- rm -fr "${D}$(python_get_sitedir)/pygame/tests"
+ # Bug #497720
+ rm -fr "${D}"$(python_get_sitedir)/pygame/{docs,examples,tests}/ || die
}
python_install_all() {
diff --git a/dev-python/pygame/pygame-1.9.2_pre3082.ebuild b/dev-python/pygame/pygame-1.9.2_pre3082.ebuild
deleted file mode 100644
index 2c999c4d1f85..000000000000
--- a/dev-python/pygame/pygame-1.9.2_pre3082.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre3082.ebuild,v 1.8 2012/02/20 14:27:51 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-
-inherit distutils virtualx
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
-if [[ "${PV}" == *_pre* ]]; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc sparc x86 ~x86-fbsd"
-IUSE="doc examples X"
-
-DEPEND="dev-python/numpy
- >=media-libs/libsdl-1.2.5[X?]
- >=media-libs/sdl-image-1.2.2[png,jpeg]
- >=media-libs/sdl-mixer-1.2.4
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/smpeg-0.4.4-r1"
-RDEPEND="${DEPEND}"
-
-if [[ "${PV}" != *_pre* ]]; then
- S="${WORKDIR}/${P}release"
-fi
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="WHATSNEW"
-
-src_configure() {
- "$(PYTHON -f)" config.py -auto
-
- if ! use X; then
- sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" run_tests.py
- }
- VIRTUALX_COMMAND="python_execute_function" virtualmake testing
-}
-
-src_install() {
- distutils_src_install
-
- delete_examples_and_tests() {
- rm -fr "${ED}$(python_get_sitedir)/pygame/examples"
- rm -fr "${ED}$(python_get_sitedir)/pygame/tests"
- }
- python_execute_function -q delete_examples_and_tests
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/pygame/pygame-1.9.2_pre3203.ebuild b/dev-python/pygame/pygame-1.9.2_pre3203.ebuild
deleted file mode 100644
index d8ba2113dfef..000000000000
--- a/dev-python/pygame/pygame-1.9.2_pre3203.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre3203.ebuild,v 1.3 2012/02/20 14:27:51 patrick Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-**"
-PYTHON_TESTS_RESTRICTED_ABIS="3.*"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils virtualx
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
-if [[ "${PV}" == *_pre* ]]; then
- SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
-else
- SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc examples X"
-
-DEPEND="dev-python/numpy
- >=media-libs/libsdl-1.2.5[X?]
- >=media-libs/sdl-image-1.2.2[png,jpeg]
- >=media-libs/sdl-mixer-1.2.4
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/smpeg-0.4.4-r1"
-RDEPEND="${DEPEND}"
-
-if [[ "${PV}" != *_pre* ]]; then
- S="${WORKDIR}/${P}release"
-fi
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="WHATSNEW"
-
-src_configure() {
- "$(PYTHON -f)" config.py -auto
-
- if ! use X; then
- sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
- fi
-
- # Automagic dep on portmidi, bug 383927.
- sed -e "s:^pypm :#&:" -i Setup || die
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" run_tests.py
- }
- VIRTUALX_COMMAND="python_execute_function" virtualmake testing
-}
-
-src_install() {
- distutils_src_install
-
- delete_examples_and_tests() {
- rm -fr "${ED}$(python_get_sitedir)/pygame/examples"
- rm -fr "${ED}$(python_get_sitedir)/pygame/tests"
- }
- python_execute_function -q delete_examples_and_tests
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}