summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-07-26 11:37:24 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-07-26 11:37:24 +0000
commit3a93aebb0497361ef1908b6d36dd9f6b9ec6a62d (patch)
treed90a0ff6d76973b0cbdf7ffa34e0943006593976 /dev-python/pytables
parentBump to the TeX Live 2012 version. (diff)
downloadgentoo-2-3a93aebb0497361ef1908b6d36dd9f6b9ec6a62d.tar.gz
gentoo-2-3a93aebb0497361ef1908b6d36dd9f6b9ec6a62d.tar.bz2
gentoo-2-3a93aebb0497361ef1908b6d36dd9f6b9ec6a62d.zip
version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog8
-rw-r--r--dev-python/pytables/pytables-2.4.0.ebuild67
2 files changed, 73 insertions, 2 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index 1ce1305dafd0..78133558352a 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytables
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.41 2012/02/23 06:48:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.42 2012/07/26 11:37:24 xarthisius Exp $
+
+*pytables-2.4.0 (26 Jul 2012)
+
+ 26 Jul 2012; Kacper Kowalik <xarthisius@gentoo.org> +pytables-2.4.0.ebuild:
+ version bump
23 Feb 2012; Patrick Lauer <patrick@gentoo.org> pytables-2.3.1.ebuild:
Restricting pypy and jython
@@ -181,4 +186,3 @@
15 Feb 2004; <kloeri@gentoo.org> pytables-0.7.2.ebuild:
Initial import.
-
diff --git a/dev-python/pytables/pytables-2.4.0.ebuild b/dev-python/pytables/pytables-2.4.0.ebuild
new file mode 100644
index 000000000000..b584722fb2c3
--- /dev/null
+++ b/dev-python/pytables/pytables-2.4.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.4.0.ebuild,v 1.1 2012/07/26 11:37:24 xarthisius Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+MY_PN=tables
+MY_P=${MY_PN}-${PV}
+
+inherit distutils
+
+DESCRIPTION="A package for managing hierarchical datasets built on top of the HDF5 library."
+HOMEPAGE="http://www.pytables.org http://pypi.python.org/pypi/tables"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+IUSE="doc contrib examples"
+
+RDEPEND="
+ sci-libs/hdf5
+ >=dev-python/numpy-1.6.0
+ dev-python/numexpr
+ dev-libs/lzo:2
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ dev-python/cython"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ANNOUNCE.txt RELEASE_NOTES.txt THANKS doc/usersguide-${PV}.pdf"
+
+src_compile() {
+ export HDF5_DIR="${EPREFIX}"/usr
+ distutils_src_compile
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tables/tests/test_all.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ pushd doc > /dev/null
+ use doc && dohtml -r html/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r scripts
+ popd > /dev/null
+
+ insinto /usr/share/${PF}
+ use contrib && doins -r contrib
+}