summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-28 13:25:24 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-28 13:25:24 +0000
commitc3b9328840f7ddc3d29d8d889259bb4e1835cfb7 (patch)
tree701f3b1a3fb948bda94fb74aff4206361fb43ad3 /dev-python/pytest-cov
parentVersion bump (diff)
downloadgentoo-2-c3b9328840f7ddc3d29d8d889259bb4e1835cfb7.tar.gz
gentoo-2-c3b9328840f7ddc3d29d8d889259bb4e1835cfb7.tar.bz2
gentoo-2-c3b9328840f7ddc3d29d8d889259bb4e1835cfb7.zip
bump, update RDEPs
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/ChangeLog9
-rw-r--r--dev-python/pytest-cov/pytest-cov-1.8.1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/pytest-cov/ChangeLog b/dev-python/pytest-cov/ChangeLog
index ee647246691b..499d68d637f5 100644
--- a/dev-python/pytest-cov/ChangeLog
+++ b/dev-python/pytest-cov/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest-cov
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-cov/ChangeLog,v 1.12 2014/12/30 10:24:06 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-cov/ChangeLog,v 1.13 2015/01/28 13:25:24 idella4 Exp $
+
+*pytest-cov-1.8.1 (28 Jan 2015)
+
+ 28 Jan 2015; Ian Delaney <idella4@gentoo.org> +pytest-cov-1.8.1.ebuild:
+ bump, update RDEPs
30 Dec 2014; Jeroen Roovers <jer@gentoo.org> pytest-cov-1.6.ebuild:
Stable for HPPA (bug #530600).
diff --git a/dev-python/pytest-cov/pytest-cov-1.8.1.ebuild b/dev-python/pytest-cov/pytest-cov-1.8.1.ebuild
new file mode 100644
index 000000000000..4e2162a4ce19
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-1.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest-cov/pytest-cov-1.8.1.ebuild,v 1.1 2015/01/28 13:25:24 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_{3,4}} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="http://bitbucket.org/memedough/pytest-cov/overview"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cov-core-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ <dev-python/coverage-4[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/virtualenv[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # test_ file produces no output; For FI
+ "${PYTHON}" test_pytest_cov.py || die "tests failed under ${EPYTHON}"
+}