summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-30 11:50:08 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-30 11:50:08 +0000
commit3747877d58f20c4676bb6190a5e8d9f1968eb9cc (patch)
tree4195ad699649f2e461dd655340aad0c07e2e820b /dev-python/python-dateutil
parentInitial commit, based on lorelei overlay version (diff)
downloadgentoo-2-3747877d58f20c4676bb6190a5e8d9f1968eb9cc.tar.gz
gentoo-2-3747877d58f20c4676bb6190a5e8d9f1968eb9cc.tar.bz2
gentoo-2-3747877d58f20c4676bb6190a5e8d9f1968eb9cc.zip
remove old obsoleted py2 only version & version inheriting old eclass; 2.2, clean old impls
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-dateutil')
-rw-r--r--dev-python/python-dateutil/ChangeLog7
-rw-r--r--dev-python/python-dateutil/python-dateutil-1.5.ebuild58
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.1.ebuild62
-rw-r--r--dev-python/python-dateutil/python-dateutil-2.2.ebuild4
4 files changed, 8 insertions, 123 deletions
diff --git a/dev-python/python-dateutil/ChangeLog b/dev-python/python-dateutil/ChangeLog
index 3ac2eaf9b658..96a21fa53ec5 100644
--- a/dev-python/python-dateutil/ChangeLog
+++ b/dev-python/python-dateutil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-dateutil
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/ChangeLog,v 1.60 2014/09/27 15:39:57 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/ChangeLog,v 1.61 2014/09/30 11:50:08 idella4 Exp $
+
+ 30 Sep 2014; Ian Delaney <idella4@gentoo.org> -python-dateutil-1.5.ebuild,
+ -python-dateutil-2.1.ebuild, python-dateutil-2.2.ebuild:
+ remove old obsoleted py2 only version & version inheriting old eclass; 2.2,
+ clean old impls
27 Sep 2014; Mike Gilbert <floppym@gentoo.org> python-dateutil-2.1-r1.ebuild:
Add python3.4 to version 2.1.
diff --git a/dev-python/python-dateutil/python-dateutil-1.5.ebuild b/dev-python/python-dateutil/python-dateutil-1.5.ebuild
deleted file mode 100644
index 1b260bde9e56..000000000000
--- a/dev-python/python-dateutil/python-dateutil-1.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/python-dateutil-1.5.ebuild,v 1.7 2011/11/26 16:26:21 hwoarang Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-
-inherit distutils
-
-DESCRIPTION="Extensions to the standard Python datetime module"
-HOMEPAGE="http://labix.org/python-dateutil http://pypi.python.org/pypi/python-dateutil"
-SRC_URI="http://labix.org/download/python-dateutil/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="python-2"
-KEYWORDS="amd64 ia64 ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
-
-RDEPEND="sys-libs/timezone-data"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-DOCS="NEWS README"
-PYTHON_MODNAME="dateutil"
-
-src_prepare() {
- distutils_src_prepare
-
- # Use zoneinfo in /usr/share/zoneinfo.
- sed -e "s/zoneinfo.gettz/gettz/g" -i test.py || die "sed failed"
-
- # Fix parsing of date in non-English locales.
- sed -e 's/commands.getoutput("date")/commands.getoutput("LC_ALL=C date")/' -i example.py
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- delete_zoneinfo() {
- rm -f "${ED}$(python_get_sitedir)/dateutil/zoneinfo/"*.tar.*
- }
- python_execute_function -q delete_zoneinfo
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins example.py sandbox/*.py
- fi
-}
diff --git a/dev-python/python-dateutil/python-dateutil-2.1.ebuild b/dev-python/python-dateutil/python-dateutil-2.1.ebuild
deleted file mode 100644
index f2bc1bb5aa5c..000000000000
--- a/dev-python/python-dateutil/python-dateutil-2.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/python-dateutil-2.1.ebuild,v 1.7 2012/12/17 17:53:41 ago Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 *-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="Extensions to the standard Python datetime module"
-HOMEPAGE="https://launchpad.net/dateutil http://pypi.python.org/pypi/python-dateutil"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples"
-
-RDEPEND="dev-python/six
- sys-libs/timezone-data
- !<dev-python/python-dateutil-2.1"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-DOCS="NEWS README"
-PYTHON_MODNAME="dateutil"
-
-src_prepare() {
- # Bug 410725.
- epatch "${FILESDIR}/${P}-open-utf-8.patch"
-
- # Use zoneinfo in /usr/share/zoneinfo.
- sed -i -e "s/zoneinfo.gettz/gettz/g" test.py || die
-
- # Fix parsing of date in non-English locales.
- sed -e 's/subprocess.getoutput("date")/subprocess.getoutput("LC_ALL=C date")/' \
- -i example.py || die
-
- distutils_src_prepare
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- delete_zoneinfo() {
- rm -f "${ED}$(python_get_sitedir)/dateutil/zoneinfo"/*.tar.*
- }
- python_execute_function -q delete_zoneinfo
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins example.py sandbox/*.py
- fi
-}
diff --git a/dev-python/python-dateutil/python-dateutil-2.2.ebuild b/dev-python/python-dateutil/python-dateutil-2.2.ebuild
index 88a2f3a0b041..ab06bb7684d4 100644
--- a/dev-python/python-dateutil/python-dateutil-2.2.ebuild
+++ b/dev-python/python-dateutil/python-dateutil-2.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/python-dateutil-2.2.ebuild,v 1.3 2014/04/16 04:43:50 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/python-dateutil-2.2.ebuild,v 1.4 2014/09/30 11:50:08 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
inherit distutils-r1